1

I bought this USB wifi dongle and I tried to install it on my Kubuntu 20.04 (Kubuntu 18.04 LTS upgraded recently to 20.04)

$lsusb
...
Bus 005 Device 002: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter
...

I followed this french tutorial that says that everything is in the repositories
So I installed rtl8812au-dkms package, it worked. Then I did sudo modprobe rtl8812au and it also worked.

But, using ifconfig and iwconfig still gives me the same result than before: my ethernet interface, my loopback interface and my PCI wifi interface. The GUI in Kubuntu does not add me any new interface.

So, as advised in the french tutorial, I followed instruction "in case if another method does not work", which is to compile the driver :

sudo apt-get install linux-headers-generic build-essential git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
make
sudo make install
sudo modprobe rtl8812au

Everything again went fine, but still no new interface.

Have I done something wrong? have I missed something? Any help appreciated :-)

13
  • Make sure that modprobe doesn't fail and post output of dmesg after running it. Apr 15, 2020 at 17:11
  • modprobe does fail now, saying "ERROR: could not insert 'rtl8812au': Device or resource busy". dmesg confirms that: "Error: Driver 'rtl8812au' is already registered, aborting..." Apr 15, 2020 at 17:36
  • @ArkadiuszDrabczyk have you got an other idea that may help me ? :-) Apr 16, 2020 at 9:51
  • I asked you to provide dmesg output when loading the driver for the first time - unload it with rmmod, load again with insmod ./rtl8812au.ko (not modprobe) and post output of dmesg. Apr 16, 2020 at 15:05
  • @ArkadiuszDrabczyk I think you found something. There is a crash somewhere while calling insmod, but insmod still have $?=0. Here is the dmesg output Apr 16, 2020 at 16:08

1 Answer 1

2

OP is using Linux 5.4 and there are several similar bug reports from Linux 5.x users. The solution is to use code from kernel-5.3 branch from this fork https://github.com/jskovjyskebankdk/rtl8812AU_8821AU_linux:

$ git clone github.com/jskovjyskebankdk/rtl8812AU_8821AU_linux && cd rtl8812AU_8821AU_linux
$ git checkout kernel-5.3

Unload previously loaded non-functioning rtl8812au:

$ sudo rmmod rtl8812au

Build a new driver and load it again:

$ make -j$(nproc)
$ sudo insmod ./rtl8812au.ko

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.