I'm trying to copy the x86_64 parts of the CentOS 8 repository from http://mirror.centos.org/centos/8/ directly to Artifactory. I've successfully copied some functions (BaseOS, extras, etc) into the local file system, then using jfrog to upload them into Artifactory, but would prefer to copy directly from the CentOS web site into the Artifactory repository.

I've tried compiling httpfs and httpfs2 on the machine Artifactory runs on, with the idea that I could mount the CentOS 8 web site locally and use jfrog rt u to copy from the “local” (fuse file system) into Artifactory, but they failed to compile (if httpfs/httpfs2 is considered a very good way to do this I'll detail the compile errors).

I've used the jfrog rt command successfully (in spite of its strange references), so am comfortable with that, but am open to any method that works.

The target in Artifactory is a directory below the RPM repository defined in Artifactory, so that rules out a couple possibilities (making a remote Artifactory repository and copying from there to the subdirectory, copying into a new Artifactory repository).

One possibility I haven't tried is copying (curl, wget, etc) directly into some OS directory that Artifactory owns (and automatically indexes?), so if that's a possibility let me know.

1 Answer 1


Rclone is a wonderful way of mounting all sorts of things, including http read-only, so the CentOS 8 repo could be mounted on the Artifactory host, and jfrog could upload it from there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .