2

I wanted to try creating a wireless hotspot for learning purposes, and followed the answers in this post. I didn't like the result, and after also trying create_ap, I decided I wanted to undo everything, which included uninstalling hostapd.

After uninstalling hostapd and restarting, my wifi no longer shows up in my network applet. Doing a rfkill list all shows a soft block:

0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I can do rfkill unblock wifi or rfkill unblock all which will change soft blocked state to no, but I am still unable to use my wifi.

Is there a way to undo the damage or reinstall my wifi? I am running Linux mint 19.3, which is based on Ubuntu 18.04. I have HWE installed.

Wireless info script dump: https://paste.ubuntu.com/p/DvZhggr6qY/

EDIT: at some point my wifi soft blocks stopped happening after rebooting. I'm unsure why.

9
  • 1
    try downloading wireless-tools (you should have them already) and running this sudo iwlist scan wlo1 if the scan returns any access points in the area then it's the network manager applet that's faulty. If you get "Network is down" then do rfkill unblock all and turn the interface on ifconfig wlo1 up – shiftas Apr 14 '20 at 6:27
  • Thanks @shiftas, you were right that I had to do ifconfig wlo1 up first. Before that, I get wlo1 Interface doesn't support scanning : Network is down. After the interface is up, iwlist scan successfully finds all my access points. My network manager GUI still doesn't show any sign of my wifi interface. – aggregate1166877 Apr 15 '20 at 1:47
  • 1
    Then try to connect to your ap using nmcli, this should be installed on linux mint by default. For a new connection nmcli dev wlo1 connect <mySSID> password <myPassword> for an existing connection nmcli con up <mySSID> or nmcli con up id <mySSID> – shiftas Apr 15 '20 at 8:06
  • @shiftas I tried nmcli dev wlo1 connect <mySSID> password <myPassword> but I get the error Error: argument 'wlo1' not understood. Try passing --help instead. Running nmcli con up <mySSID> returns Error: unknown connection <MySSID> (I put in my real SSID). I also tried nmcli device wifi connect <MySSID> password "$pass" but got Error: No network with SSID '<MySSID>' found. – aggregate1166877 Apr 15 '20 at 22:06
  • 1
    @shiftas I found the problem. I did a grep wlo1 /etc/ -R and found an entry in /etc/NetworkManager/NetworkManager.conf under [keyfile]: unmanaged-devices=interface-name:wlo1. I commented out that line with a # and then did a service network-manager restart, and my wifi showed up :D. I would not have come to this answer without your help, so if you detail this as an answer, I'll be happy to accept it. – aggregate1166877 Apr 17 '20 at 2:51
0

I'll assume your network device is wlan0 for demonstration purposes. Replace wlan0 with the name of your own interface. The interface name can be checked with ifconfig -a.

Bring the interface up

First off, start by doing ifconfig wlan0 up.

Check for soft blocks

Check if your device is soft blocked by running rfkill list all:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

If you have a soft block on your wireless device, run sudo rfkill unblock wifi. This persisted for me after reboots.

Check for Network Manager problems

Determine if your NetworkManager is still managing your Wi-Fi by running nmcli or nmcli dev status. If it's marked as unmananged, you can try dev set wlan0 managed yes.

If this does not work for you, check /etc/NetworkManager/NetworkManager.conf. In my case, I had these offending lines:

[keyfile]
unmanaged-devices=interface-name:wlan0

I commented out the unmanaged-devices= line by putting a # in front of it and then running service network-manager restart, which resolved the issue for me.

Other checks

More generally, you can try grep wlan0 /etc/ -R and inspect whatever files show up (this is how I discovered the unmanaged Wi-Fi line in Network Manager confs). Be sure to make backups of whatever you change.

Additionally, there are some troubleshooting commands in the comments of the original question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.