enter image description here

NVIDIA is selected in nvidia-settings, however system info shows that the graphics card being used is Intel Graphics.

So, am I interpreting something wrong?

If not, why this does not work?


edit: I figured out that nvidia does not show up in lspci quest with "VGA".

muyustan@mint:~$ lspci -k | grep -A 2 -i "VGA"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
    Subsystem: Lenovo HD Graphics 530
    Kernel driver in use: i915

muyustan@mint:~$ lspci -k | grep -A 2 -i "nvidia*"
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
  • Some computers have an option to disable the default graphics in BIOS. Commented Apr 13, 2020 at 20:09

1 Answer 1


The pic is the nvidia config, not the driver selection ! You have to switch drivers see in the 'Drivers' program : enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .