5

I have a laptop with Ubuntu Eoan. Single soundcard, single headphone jack.

I want to use both laptop speakers and headphones at the same time (no particular reason why, just because) but as soon as I plug in the headphones, the speakers become unavailable.

I tried enabling simultaneous output, removing -switch-on-connect and -switch-on-port-available modules and making a virtual sink, but nothing works. Google search returns only the reverse problem, of people not wanting speakers and headphones to play at the same time.

Anyone has any solutions?

Output of amixer -c0:

 Capabilities: pvolume pvolume-joined pswitch pswitch-joined
 Playback channels: Mono
 Limits: Playback 0 - 87
 Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
 Capabilities: pvolume pswitch
 Playback channels: Front Left - Front Right
 Limits: Playback 0 - 87
 Mono:
 Front Left: Playback 87 [100%] [0.00dB] [on]
 Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
 Capabilities: pvolume pswitch
 Playback channels: Front Left - Front Right
 Limits: Playback 0 - 87
 Mono:
 Front Left: Playback 0 [0%] [-65.25dB] [off]
 Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
 Capabilities: pvolume
 Playback channels: Front Left - Front Right
 Limits: Playback 0 - 255
 Mono:
 Front Left: Playback 255 [100%] [0.00dB]
 Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
 Capabilities: pvolume pswitch
 Playback channels: Front Left - Front Right
 Limits: Playback 0 - 31
 Mono:
 Front Left: Playback 0 [0%] [-34.50dB] [off]
 Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
 Capabilities: volume
 Playback channels: Front Left - Front Right
 Capture channels: Front Left - Front Right
 Limits: 0 - 3
 Front Left: 0 [0%] [0.00dB]
 Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
 Capabilities: pswitch pswitch-joined
 Playback channels: Mono
 Mono: Playback [off]
Simple mixer control 'Capture',0
 Capabilities: cvolume cswitch
 Capture channels: Front Left - Front Right
 Limits: Capture 0 - 63
 Front Left: Capture 47 [75%] [18.00dB] [on]
 Front Right: Capture 47 [75%] [18.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
 Capabilities: enum
 Items: 'Disabled' 'Enabled'
 Item0: 'Enabled'
Simple mixer control 'Internal Mic',0
 Capabilities: pvolume pswitch
 Playback channels: Front Left - Front Right
 Limits: Playback 0 - 31
 Mono:
 Front Left: Playback 0 [0%] [-34.50dB] [off]
 Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Internal Mic Boost',0
 Capabilities: volume
 Playback channels: Front Left - Front Right
 Capture channels: Front Left - Front Right
 Limits: 0 - 3
 Front Left: 0 [0%] [0.00dB]
 Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Loopback Mixing',0
 Capabilities: enum
 Items: 'Disabled' 'Enabled'
 Item0: 'Disabled'
4
1

Speakers are muted when headphones are plugged in by this setting in ALSA

Simple mixer control 'Auto-Mute Mode',0
 Capabilities: enum
 Items: 'Disabled' 'Enabled'
 Item0: 'Enabled'

change this to Disabled

amixer -c0 sset 'Auto-Mute Mode' Disabled

and save ALSA settings so that ALSA keeps settings when system is restored

sudo alsactl store

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.