4

I'm running Fedora 31 Security Lab updated to the latest on Acer, with wireless driver ath10k_pci. The case is is that when i run airmon-ng there are no captured packets. Does the hardware is problematic or the driver?
I've stopped the Network Manager , then ran airmon-ng check kill and then airmon-ng it shows that wlp3s0mon is started but nothing captured.
Also tried without airmon. Checked iwlist and it does not show monitor but when i run iwconfig wlp3s0 mode monitor and check again with iwconfig it shows Mode:Monitor but still no captured packets. No errors in dmesg, rfkill is 'unblocked' and the adapter is detected and properly running when not in Monitor. I`ve read in the Qualcom's forum that QCA9377 can't operate in monitor but I was not sure because of the driver or the hardware.

2 Answers 2

6

This is a firmware issue. Earlier versions supported monitor mode, but this was eventually dropped. They can still be found at kernel.org.

You can get monitor mode to work by downgrading your firmware, using the procedure below. Be aware, though, that this will not add support to packet injection, only monitor mode.

The last commit that still supports monitor mode is from 6/22/2017. At the time of writing, the only file that has changed since is "firmware-5.bin", so you can keep the others. You need to delete file "firmware-6.bin", too, and reload the driver (via modprobe, or just reboot) before changes take effect.

Run the following from a terminal window (you may want to backup any files before replacing or deleting them):

$ git clone https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/

$ cd linux-firmware/ath10k/QCA9377/hw1.0/

# Uncomment in case you want to check the logs for QCA9377
# $ git log .

# The last commit that still supports monitor mode is dd5fba3a56bbb4c4a72576faa19f8bd45fed7ef6
$ git checkout dd5fba3a56bbb4c4a72576faa19f8bd45fed7ef6
    
$ sudo cp firmware-5.bin /lib/firmware/ath10k/QCA9377/hw1.0/
$ sudo rm /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin
1
  • 1
    could someone please mark this as the answer and provide Guilherme 1000K points ?! this saved days of frustrated attempts being discarded in oblivion... I really did try every single different approach available on google. This is the only thing that worked for this NIC.
    – Veverke
    Commented Oct 9, 2021 at 21:12
1

After some days in research and testing on second distro (Ubuntu), the conclusion is that this adapter does not support monitor (or at least not with the default drivers) so I bought TL-WN823N USB adapter. It is cheap and monitor mode works like charm. So if anyone encounters this problem - this is my solution

2
  • this should not be the selected answer. Guilherme Rios one above is what solves the problem depicted in this post. Moreover, it is the ONLY working solution available on the internet. I did try most if not all of them - if you are hesitant, feel free to waste a couple of days on your own.
    – Veverke
    Commented Oct 9, 2021 at 21:15
  • @Veverke the accepted answer is a personal choice of the person who asked the question. Angel is the person who asked so it is completely up to them what they choose to accept. The accepted answer is often not the best one, it is just the one chosen by the OP, don't give it any more importance than that.
    – terdon
    Commented Oct 10, 2021 at 11:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .