4

Up front, I found this answer and it didn't help (read below).


I am using vanilla-gnome-desktop in Ubuntu 18.04 and I have not been able to pass through special keys like Windows (aka Super) to the session connected in Remmina.

I have assigned that key (Super) to a number of global shortcuts in the GNOME shell for convenience (e.g. Super+T for Terminal and Super), though.

However, as I understand it Remmina should be able to do just that by activating a sort of "grab all keys" mode with Control_R (right Ctrl key). And indeed hitting that key toggles the respective icon in that floating bar Remmina provides when inside a connected session. However, it appears to have no effect whatsoever. The following screenshot illustrates the icon/button (and underlying setting) I mean:

Grab all keyboard events setting

For example hitting Alt+F4 simply closes the Remmina window, instead of closing whatever window I have focused inside the session. Hitting Super will open that quick launch thingamy (no idea what the proper term is) and not the start menu inside the session.

The keyboard settings for Remmina look as follows:

Remmina - Keyboard settings

So what am I doing wrong here?

My goal is to have Remmina (and thus the connected session) receive the maximum number of special keys, although it's perfectly acceptable to have an "escape" like in virtualization GUIs.

2 Answers 2

2

There is another Workaround for this. I had the same behavior in xfreerdp. I've found a solution on reddit:

https://www.reddit.com/r/archlinux/comments/elp2lf/cant_grab_input_in_fullscreen_apps_like_vms/

I run the following in my terminal:

settings set org.gnome.mutter.wayland xwayland-grab-access-rules "['xfreerdp']"

Now, the keys works and i can continue using Wayland.

1

It was a long shot, but I figured I should give it a try.

GNOME uses Wayland as the default display server. But there was a chance that this was the underlying cause for my issues (it was, read on).

So I decided to reconfigure my GNOME to use Xorg as the display server, based on this Fedora-based article. The steps are as follows:

  • Open /etc/gdm/custom.conf and uncomment WaylandEnable=false.
  • Add the following line to the [daemon] section:
    DefaultSession=gnome-xorg.desktop
  • Save the custom.conf file.

After restarting the GNOME session that "Grab all keyboard events" mode works like a charm.


With 20.04 and the packaged version of Remmina it works fine, despite using Wayland.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.