0

I use my PGP key as ssh private key to log into almost all my ssh servers (thanks to gpg-agent). I now want to connect to it with SFTP via nautilus, but every time I try I get a 'Access denied' popup.

From what I gathered through my research, Nautilus use sshfs (it probably changed, most of the article I saw was dated 2010, and it wasn't installed on my machine). So I tried and I can mount it via sshfs, but when I try again from nautilus I still get a 'Permission denied' popup.

I found a way to get the log, and effectively, it's a key issue :

sftp: stderr: jangberry@<MyServerIP>: Permission denied (publickey).

While ssh-agent haven't any key and the only key gpg-agent may use is authorized on this server

| improve this question | | | | |
  • Do you mean your private ssh key? – user3417815 Apr 7 at 3:07
  • @user3417815 I mean I use a key from my gpg keyring as a shh key... (I edited the post to clarify about it) – Jangberry Apr 7 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.