0

I was attempting to upgrade from Debian 9 (Stretch) to Debian 10 (Buster). However, while my sudo apt full-upgrade command was running (after changing my sources.list file), my connection to my server ended. When I attempt to try this command again, (or any apt install command) I get this output:

> sudo apt full-upgrade

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 anthy : Depends: libanthyinput0 but it is not installed
 libuim-plugins : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim : Depends: uim-common (= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-anthy : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-fep : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-gtk2.0 : Depends: uim (= 1:1.8.8-4+deb10u2) but 1:1.8.6+gh20161003.0.d63dadd-2 is installed
              Depends: uim-gtk2.0-immodule (= 1:1.8.8-4+deb10u2) but it is not installed
              Depends: uim-data (>= 1:1.8.8-4+deb10u2) but it is not installed
 uim-gtk3 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-qt : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-qt5 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-utils : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-xim : Depends: uim (>= 1:1.8.8-4+deb10u2) but 1:1.8.6+gh20161003.0.d63dadd-2 is installed
           Depends: uim-data (>= 1:1.8.8-4+deb10u2) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

The error message suggests running atp --fix-broken install, however when I try running this I am faced with another error:

> sudo apt --fix-broken install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  aspell-de-alt bdf2psf debian-zh-faq-s doc-debian-fr doc-linux-fr-text doc-linux-pl doc-linux-pl-html docbook-xml fortune-zh gir1.2-clutter-gst-3.0 gir1.2-evince-3.0 gir1.2-gnomekeyring-1.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtksource-3.0 gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gnome-bluetooth gnome-sushi iputils-arping libavahi-gobject0 libbind9-140 libblas-common
  libcdio-cdda1 libcdio-paranoia1 libdns162 libenca0 libfcitx-gclient0 libfcitx-qt0 libfile-copy-recursive-perl libgcr-3-common libgfortran3 libgmime-2.6-0 libgnome-autoar-0-0 libgnome-autoar-common
  libgom-1.0-common libgtksourceview-3.0-1 libgtksourceview-3.0-common libgweather-3-6 libical2 libisc160 libisccc140 libisccfg140 libjim0.76 liblvm2app2.2 liblvm2cmd2.02 liblwres141 libmusicbrainz5-2
  libmusicbrainz5cc2v5 libnfs8 libntfs-3g871 libpcre16-3 libperl5.24 libpoppler64 libprotobuf10 libqt4-designer libqt4-qt3support libqt4-script librarian0 libruby2.3 libscim8v5 libsodium18
  libsuitesparseconfig4 libtelepathy-glib0 libtracker-sparql-1.0-0 libtxc-dxtn-s2tc libxfont1 linux-headers-4.9.0-11-amd64 linux-headers-4.9.0-11-common linux-image-4.9.0-11-amd64 manpages-fr manpages-fr-extra
  myspell-bg myspell-ca myspell-en-gb myspell-it myspell-ku myspell-lt myspell-lv myspell-pl myspell-pt-br myspell-pt-pt myspell-sl myspell-th nautilus nautilus-data rarian-compat rename rsync ruby2.3 scim
  scim-chewing scim-gtk-immodule scim-im-agent scim-modules-socket sgml-data tcpd xml-core
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libanthyinput0 uim uim-anthy uim-data uim-fep uim-gtk2.0-immodule uim-gtk3 uim-gtk3-immodule uim-plugins uim-qt5 uim-qt5-immodule
The following packages will be REMOVED:
  libanthy0 libuim-plugins uim-qt uim-utils
The following NEW packages will be installed:
  libanthyinput0 uim-data uim-gtk2.0-immodule uim-gtk3-immodule uim-plugins uim-qt5-immodule
The following packages will be upgraded:
  uim uim-anthy uim-fep uim-gtk3 uim-qt5
5 upgraded, 6 newly installed, 4 to remove and 234 not upgraded.
4 not fully installed or removed.
Need to get 0 B/1,558 kB of archives.
After this operation, 4,196 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
dpkg: considering deconfiguration of uim-anthy, which would be broken by installation of uim-data ...
dpkg: yes, will deconfigure uim-anthy (broken by uim-data)
(Reading database ... 219579 files and directories currently installed.)
Preparing to unpack .../uim-data_1%3a1.8.8-4+deb10u2_all.deb ...
De-configuring uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: error processing archive /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb (--unpack):
 installed uim-anthy package pre-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I may be able to complete a full system restore if I need to, but since everything else on my system seems operable I was hoping there was some other way to fix this error. I supposedly have successfully upgraded to Debian 10 (Buster), as shown by the output of my lsb_release command.

> lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

EDIT: I have also tried clearing the issue using dpkg, but it also gives me an error.

> sudo dpkg --configure -a

dpkg: dependency problems prevent configuration of uim-xim:
 uim-xim depends on uim (>= 1:1.8.8-4+deb10u2); however:
  Version of uim on system is 1:1.8.6+gh20161003.0.d63dadd-2.
 uim-xim depends on uim-data (>= 1:1.8.8-4+deb10u2); however:
  Package uim-data is not installed.

dpkg: error processing package uim-xim (--configure):
 dependency problems - leaving unconfigured
Setting up uim-mozc:amd64 (2.23.2815.102+dfsg-4) ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: error processing package uim-mozc:amd64 (--configure):
 installed uim-mozc:amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of anthy:
 anthy depends on libanthyinput0; however:
  Package libanthyinput0 is not installed.

dpkg: error processing package anthy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of uim-gtk2.0:
 uim-gtk2.0 depends on uim (= 1:1.8.8-4+deb10u2); however:
  Version of uim on system is 1:1.8.6+gh20161003.0.d63dadd-2.
 uim-gtk2.0 depends on uim-gtk2.0-immodule (= 1:1.8.8-4+deb10u2); however:
  Package uim-gtk2.0-immodule is not installed.
 uim-gtk2.0 depends on uim-data (>= 1:1.8.8-4+deb10u2); however:
  Package uim-data is not installed.

dpkg: error processing package uim-gtk2.0 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 uim-xim
 uim-mozc:amd64
 anthy
 uim-gtk2.0

I also get an error when attempting to remove some of the broken packages such as anthy and libuim-plugins:

> sudo apt remove anthy libuim-plugins

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 uim : Depends: uim-common (= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-anthy : Depends: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not going to be installed
             Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
             Depends: anthy but it is not going to be installed
 uim-fep : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-gtk2.0 : Depends: uim (= 1:1.8.8-4+deb10u2) but 1:1.8.6+gh20161003.0.d63dadd-2 is to be installed
              Depends: uim-gtk2.0-immodule (= 1:1.8.8-4+deb10u2) but it is not going to be installed
              Depends: uim-data (>= 1:1.8.8-4+deb10u2) but it is not going to be installed
 uim-gtk3 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-qt : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-qt5 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-utils : Depends: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not going to be installed
             Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
 uim-xim : Depends: uim (>= 1:1.8.8-4+deb10u2) but 1:1.8.6+gh20161003.0.d63dadd-2 is to be installed
           Depends: uim-data (>= 1:1.8.8-4+deb10u2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Any ideas on how to fix these broken dependencies?

0

Remove anthy , uim* and libuim-plugins :

sudo dpkg --configure -a
sudo apt remove anthy libuim-plugins
sudo apt remove uim.

then upgrade:

sudo apt update
sudo apt upgrade
sudo apt full-upgrade
sudo apt --purge autoremove

Reinstall anthy and uim:

sudo apt install anthy uim

You dont need to install libuim-plugins, it is only available for debian 9.

Update:

Problem solved by removing anthy and all related package to uim (uim*) from /var/lib/dpkg/status then:

sudo dpkg --configure -a
| improve this answer | |
  • 1
    I tried running the first two commands, but they give me more errors and don't appear to work. See my edited question for more info. – dguis Apr 5 at 20:56
  • @dguis I have edited my answer, could you try it , please. – GAD3R Apr 5 at 21:55
  • @dguis the uim package seems to be buggy due to libuim-data bug. – GAD3R Apr 5 at 21:58
  • Yes, that is what it seems like. I tried to copy the uim.postrm file, but it doesn't appear to exist. cp: cannot stat '/var/lib/dpkg/info/uim.postrm': No such file or directory – dguis Apr 5 at 21:59
  • @dguis please check my answer (the update) unix.stackexchange.com/a/560280/153195 – GAD3R Apr 5 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.