0

I've configured Docker on my Ubuntu 18.04 Server to expose its API so I can create and deploy Docker containers via REST requests, which I need to add certain features to my project. This worked fine for first few endpoints I tried. However, when I attempt to create a new Docker container (the main point of the exercise), I get the message:

{"message": "Your kernel does not support cgroup cpu real-time period"}

Is this true? Alternatively is it instead that I need to set something up to enable this functionality, or is Docker reporting incorrectly?

curl -X POST -H "Content-Type: application/json" -d "@./test-data/docker-create-api-test.json" http://localhost:1112/containers/create
{"message":"Your kernel does not support cgroup cpu real-time period"}

Very grateful for any assistance given as this functionality is critical to my project.

16
  • Please edit the question to show the docker command that produces this. (Not via your interface, and not speculation. Test it). Commented Apr 5, 2020 at 14:24
  • @ctrl-alt-delor Added but by definition this is not a Docker command in any usual sense. The Docker API is a REST API which is supposed to function via REST calls such as the curl call pictured above. docs.docker.com/engine/api docs.docker.com/engine/api/v1.40/#operation/ContainerList . I have altered my environment variables to expose this API via http (tcp) which by default is served via the unix protocol. Commented Apr 5, 2020 at 14:53
  • well recompiling the kernel with this option (cateee.net/lkddb/web-lkddb/RT_GROUP_SCHED.html) could be an option
    – A.B
    Commented Apr 5, 2020 at 14:57
  • That sounds pretty hardcore. I'll look into it. Commented Apr 5, 2020 at 14:58
  • 1
    My guess that all the information is in that json file. Commented Apr 5, 2020 at 15:11

1 Answer 1

0

In the official Docker example that I had wrongly assumed would work as a test body, there was the following line:

"CpuRealtimePeriod": 1000000,

Which sets a value that, it seems, is not supported by most or perhaps any out of the box Linux distros. Arch Linux master race ;).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .