0

when I tried to upgrade my kali linux to its 2020 version, its always returns with error code:

dpkg: error processing archive /var/cache/apt/archives/kali-themes_2020.2.1_all.deb (--unpack):
dpkg: error processing archive /var/cache/apt/archives/ruby-progressbar_1.10.1-1_all.deb (--unpack): 
trying to overwrite '/usr/lib/ruby/vendor_ruby/ruby-progressbar/base.rb' which is also in package ruby-ruby-progressbar 1.6.0-0kali1
E: Sub-process /usr/bin/dpgk returned with error code (1)

and when I finished doing sudo dpkg --configure -a, it said :

**dpkg**: dependency problems prevent configuration of ruby-cms-scanner:
ruby-cms-scanner depends on ruby-progressbar (>=1.9.0); however:
pacakge ruby-progressbar is not installed

**dpkg**: error processing package ruby-cms-scanner(--configure):
dependency problems - leaving unconfigured

**dpkg**: dependency problems prevent configuration of gnome-theme-kali:
gnome-theme-kali depends on kali-themes; however:
package kali-themes is not installed.

**dpkg**: error processing package gnome-theme-kali (--configure):
dependency problems - leaving unconfigured

**dpkg**: dependency problems prevent configuration of wpscan:
wpscan depends on ruby-cms-scanner; however:
package ruby-cms-scanner is not configured yet.

**dpkg**: error processing package wpscan (--configure):
dependency problem - leaving unconfigured

    errors were encountered while processing:
    ruby-cms-scanner
    gnome-theme-kali
    wpscan

I have tried: sudo apt-get install -f sudo apt-get autoclean sudo apt-get install aptitude(somehow I cant install it) sudo apt-get -u dist-upgrade

and I cant even purge or remove theme

what should I do? I used Virtual Box to run my Kali too. Please give me step by step of how to solve this error.

  • 1
    Are you using kali as a general purpose desktop operating system? – ctrl-alt-delor Apr 5 at 12:25
  • 1
    I use it for my collegue studies, so this os is very important to me, for pen test, hacking and stuff – Gebrina Divva Meuthia Zulma Apr 5 at 12:36
  • 1
    Install Debian, for a reliable desktop system. For you pen-test stuff, just re-install kali. – ctrl-alt-delor Apr 5 at 12:38
  • 1
    omg so are you saying I cant save this os and I should make a new one?there should be another way, I mean, all of my progress is kinda in there... – Gebrina Divva Meuthia Zulma Apr 5 at 12:39
  • 1
    I am not saying that it can't be done. But please read this unix.meta.stackexchange.com/q/5316/4778 – ctrl-alt-delor Apr 5 at 12:45
0

I had the exact same thing, run:

sudo dpkg -P ruby-ruby-progressbar

and then continued the installation with:

sudo apt --fix-broken install -y
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.