0

Running on Debain 10 buster, with KDE plassa 5 * KDE Frameworks 5.54.0 * Qt 5.11.3 (built against 5.11.3) * The xcb windowing system

I'm using wh1000mx3, which succeeded to pair but not able to chose the A2DP profile automatically. Usually the HSP/HFP profile appear. Moreover, the profile randomly succeed (1 of 15 attempts) or when the Bluetooth device is forgotten.

I'm using the "gdm session" and the solution from official detain A2DP page is relevant. https://wiki.debian.org/BluetoothUser/a2dp

The solution on this web didn't help as well. Error when trying to connect to bluetooth speaker: `org.bluez.Error.Failed` How to force A2DP sink when wireless bluetooth headset is connected?

Please assist :)

Thanks,

sec_user

0
0

I have experienced the same bug in Debian 10, and it appears not to be resolved in any upstream (backport / testing / compiled from source) bluetooth components.

However, you can work around this by causing a software reconnect so you can use your headphones in the correct mode. Unfortunately you have to do this every time you turn on the headphones. You can do this by:

  1. Turning on your headphones (which should auto-connect in HSP / the wrong mode)
  2. Opening the "Bluetooth Devices" panel
  3. Right-click the device and "Disconnect"
  4. Wait for this to be reflected in the devices panel
  5. Right-click the device, Connect to -> select "Audio Sink"
  6. Right-click the device, Audio Profile -> select "A2DP Sink"

For the XM3s you may also be interested in LDAC, though the built in codec is plenty good enough.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.