4

How can I disable these warnings about ECC? I don't have ECC memory and so disabled it in bios also but it still prints it.

[    4.697057] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.697061] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    4.764909] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.764911] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    4.844621] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.844624] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    4.889875] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[    4.892678] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.892681] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    4.913651] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
[    4.936635] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.936637] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    4.949722] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[    4.980600] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.980602] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[    5.028880] EDAC amd64: Node 0: DRAM ECC disabled.
[    5.028883] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
4
  • Have you tried blacklisting the module? echo 'blacklist ecc' >> /etc/modprobe.d/blacklist.conf – kurcze Apr 2 '20 at 9:27
  • No I didn't I just happened to notice it in a log file. – JoKeR Apr 2 '20 at 9:33
  • I will try to and see the result – JoKeR Apr 2 '20 at 9:34
  • it doesn't work – JoKeR Apr 2 '20 at 10:25
3

If you don't have an ECC-capable memory, you can try to find and subsequently disable this spammy module:

find /lib/modules/$(uname -r) -type f -name '*.ko' | grep _edac

There will be quite a lot of *_edac* modules, but in your case the culprit module is amd64_edac_mod (as hinted in the error message).

Then all you have to do is to put this module into the blacklist file:

echo "blacklist amd64_edac_mod" >> /etc/modprobe.d/blacklist.conf

Reboot, voilà! — the module is not attempted to be loaded anymore and the error is gone.

2
  • 1
    Thank you for the hint. – JoKeR Aug 19 '20 at 8:48
  • You're very welcome! – Neurotransmitter Aug 19 '20 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.