1

I recently tried to install Arch linux. When I booted into Arch linux setup from bootable usb drive, I tried the wifi-menu command to connect to my mobile hotspot but it just said to use netctl. When I used the wifi-menu command on my Ubuntu, on which I have installed the realtek wifi-drivers manually, it worked perfectly and showed the available wifi-hotspots. So I think I must have to install the wifi-drivers on Arch before I can access the wifi-menu. I have the wifi-driver source in my Internal hard disk (D drive) which I was able to access through Ubuntu live boot, how can I access that folder from the arch linux setup?

1
  • Hi, have you been through the section on the Arch wiki about wireless setup? Arch usually requires more setup/configuration than Ubuntu. Have you installed NetworkManager? Also, which desktop environment are you using?
    – Time4Tea
    Apr 2, 2020 at 22:55

1 Answer 1

0

You could also just install them using USB tethering from your phone. Just look up the name of your wireless chip and install them: e.g.: I used sudo pacman -S broadcom-wl for my broadcom wifi adapter.

3
  • I cannot, even USB Tethering is not working. When I turn on USB Tethering, nothing happens at all. Apr 6, 2020 at 13:16
  • Type ip a into terminal. This should show 2 devices: one for loopback, and one for tethering.
    – user398085
    Apr 6, 2020 at 14:25
  • HI, I was finally able to connect through USB tethering, first, I listed my devices using ip link -a . The USB tethering device had a MAC Address of all zeroes, so first, I had to change the mac address to a non zero one, which I again did using IP Link, and then ran the dhclient command, it started working. In pop_os though, instead of dhclient command, I had to use ip link set <device name> up command. Apr 8, 2020 at 10:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .