0

Any help is greatly appreciated!

Edit: also forgot to include that launching on my Windows SSD boots perfectly. And the odd time it will launch with hanging at the Mint logo (not sure how to reproduce, seems random as no settings changed just a reboot)

Today I removed my CPU and applied new thermal paste then insert it back in. BIOS appeared as though everything was fine, temps were fine as well. However on launch it appeared with "new cpu installed" then brought me to BIOS.

I simply closed BIOS and proceeded to launch Linux Mint.

I have 2 SSD's in my PC, one has Windows installed which I never use , it was just an old drive.

Upon loading Linux Mint, it appeared with an error saying kernel panic.

My first time installing Linux Mint on the PC was over a year ago. I ran in to some similar issues transitioning from Windows to using Mint. I do not remember exactly how I fixed it as it was some time ago and I spent probably 2-3 days researching and trying different things.

I believe I fixed it by editing the kernel parameters at the time and managed to get it to successfully install.

Ever since, every time I boot Mint it appears with the "amd-vi completion wait loop timed out" for about 15-20 lines and then it appears with the boot logo, then boots fine. This became normal and I was used to it as for years it appeared this way.

Now when booting it appears with the same thing, only instead of booting to Mint it then proceeds to show many lines of text before pausing upon the "end kernel panic"

I have spent 2 days researching and tried many suggestions. I will list a few below.

Attempted to change to "Legacy OPROM" for "Boot Device Control". After booting it brings me straight to BIOS, I assume it does not recognize the drives. So I reverted to "UEFI and Legacy OPROM"

Disabled "SVM Mode" (CPU Virtualization) in CPU configuration. First boot after this it brought me to login screen of Linux Mint, I logged in only for it to appear with my mouse cursor and all black screen. As if nothing was loading. I tried to replicate this and get it back to that point but have not been able to since yesterday.

Tried a long list of different kernel parameters. Most cause it to launch into BusyBox shell.

Tried changing the boot kernel in "advanced options" from GRUB menu. I tried all 5 listed, including the recovery mode version for each. No difference, all bring me to end kernel panic.

(Probably overkill) I changed the kernel parameters for all 5 kernels including recovery mode ones, to see if any of them would work.

I am trying to remember what K had to do in order for Linux Mint to install correctly last year, I believe it was one of the IOMMU kenerl parameters that solved it, but I do not know for sure.

The kernel parameters I attempted were the ones listed here: amd-vi completion wait loop and other errors/messages in my attempt to install Arch Linux on blank SSD

Linux Mint version is 19.3

Kernel versions are: 5.3.0-42, 5.3.0-40, 5.0.0-32, 4.15.0-91, 4.15-0-54

0

Solved.

For anyone reading this in the future.

If you can get to the BusyBox shell, I got there from editing the kernel parameters to "IOMMU=off", then you enter the following commands

"Exit"

Will return the location of your filesystem, mine was "/dev/sda2"

Next enter "fsck /dev/sda2 -y"

Replace /dev/sda2 with the location of your filesystem.

After a little time it showed the filesystem was modified and completed. Next reboot. Should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.