2

When I try to suspend my Ubuntu ASUS laptop, it immediately wakes up. The laptop is a few months old and as far as I can remember, I've always had the issue. I tried to solve this problem with numerous solutions, but none worked.

I already tried to set all the fields in the /proc/acpi/wakeup file to disabled. I also tried to disable my secondary Nvidia graphics card because I've seen that it may be an issue (I'm not sure if I actually succeeded in doing that but I don't know how to check that).

dmesg output :

[   57.214218] PM: suspend entry (s2idle)
[   61.995781] Filesystems sync: 4.787 seconds
[   62.000447] Freezing user space processes ... (elapsed 0.003 seconds) done.
[   62.004139] OOM killer disabled.
[   62.004140] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[   62.005597] printk: Suspending console(s) (use no_console_suspend to debug)
[   62.007240] wlo1: deauthenticating from 24:7f:20:aa:03:56 by local choice (Reason: 3=DEAUTH_LEAVING)
[   62.402707] pci 0000:01:00.0: Enabling HDA controller
[   62.421668] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[   62.540601] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[   62.608208] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
[   62.631788] OOM killer enabled.
[   62.631790] Restarting tasks ... done.
[   62.666222] PM: suspend exit
[   62.726320] ata3: SATA link down (SStatus 4 SControl 300)
[   66.418569] wlo1: authenticate with 24:7f:20:aa:03:56
[   66.427189] wlo1: send auth to 24:7f:20:aa:03:56 (try 1/3)
[   66.467410] wlo1: authenticated
[   66.471843] wlo1: associate with 24:7f:20:aa:03:56 (try 1/3)
[   66.476075] wlo1: RX AssocResp from 24:7f:20:aa:03:56 (capab=0x1411 status=0 aid=3)
[   66.482586] wlo1: associated
[   66.482657] wlo1: Limiting TX power to 20 (20 - 0) dBm as advertised by 24:7f:20:aa:03:56
[   66.523036] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready

How can I solve this problem ? Any information on how to debug this situation is welcome.

2
  • Had that recently with 19.10 but it was my USB mouse and could be disabled with echo "XHC" >> /proc/acpi/wakeup. What do you write to /proc/acpi/wakeup? As far as I understand it it is really the system BIOS that wakes the system, so maybe you could check wake up sources in the BIOS. – xenoid Mar 31 '20 at 16:21
  • I disabled everything in /proc/acpi/wakeup and no changes. After I asked the question, i tried to add no_console_suspend and other options to the kernel options to see what's going on and no informations. So I did a fresh install and the problem isn't here anymore. Thanks for the answer, maybe it was the BIOS as you said, no way of knowing now ;) – Oscar Guérin Apr 1 '20 at 8:03
0

I had this issue when bluetooth was on. Try turning it off and suspend.

Run systemctl disable bluetooth to keep bluetooth off on the reboots. You can still manually enable as needed.

1
  • I tried that but that's not it. Good idea though :) – Oscar Guérin Apr 1 '20 at 8:03
0

Had this issue and I struggled to to find the source for a few days. My solution was to first search the log journalctl -b | grep suspend

I found the following:

PM: Device 0000:05:00.0 failed to suspend async: error 1

This line provided the device address that created this issue Than I used lspci to identify the device 05:00.0 ASmedia usb 3.1

Using lspci shows the actucal names of devices by address and In my case I remembers seing this on my ASRock Bios so I rebooted disables the support for ASmedia usb 3.1 and my Desktop suspended successfuly.

My case is uniqe to me but might help other identify the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.