2

I'm using CentOS 7 with XFCE and GDM.

My issue is as follows: I want my locale to be LANG=fr_FR.iso88591 (required by an antic piece of software).

Following CentOS official guide, I did the following:

$ localectl list-locales | grep fr_FR
fr_FR
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
fr_FR@euro
$ sudo localectl set-locale LANG=fr_FR.iso88591

I can check this actually worked:

$ cat /etc/locale.conf
LANG=fr_FR.iso88591
$ localectl
   System Locale: LANG=fr_FR.iso88591
       VC Keymap: fr
      X11 Layout: fr
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp

However, after reboot(s), this happens:

$ echo $LANG
fr_FR.UTF-8

It looks like gdm or Xfce are resetting the locale to UTF-8. But having grepped all my ~/.* files for UTF string, I cannot find where this happens and it drives me mad!

Would you happen to know what is going on here?

0

It happens that gdm saves the LANG variable for <user_name> in the file:

/var/lib/AccountsService/users/<user_name>

One just needs to change the LANG setting there, log out and then back in!

More info here: https://help.gnome.org/admin/system-admin-guide/stable/session-user.html.en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.