I am trying to install a program (zoom) on a Linux Fedora 29 64bit installation. I think I have all prerequisites installed, but one problem remains

[root@myhost~]# ldd /opt/zoom/zoom | more
/opt/zoom/zoom: /lib64/libQt5Quick.so.5: version `Qt_5_PRIVATE_API' not found (required by /opt/zoom/zoom)

The related package qt5-qtdeclarative-5.11.3-1.fc29.x86_64 is already installed. How do I resolve this?

Update for requested info:

[root@myhost~]# updatedb && locate libQt5Quick.so.5
[root@myhost~]# strings -d /usr/lib64/libQt5Quick.so.5 | grep Qt.*API
  • 1
    Add the output of updatedb && locate libQt5Quick.so.5 and strings -d /path/to/libQt5Quick.so.5 | grep Qt.*API to your question. Commented Mar 28, 2020 at 22:09
  • I've updated the question. I notice the string doesn't match...but don't know what to make of that
    – TSG
    Commented Mar 28, 2020 at 22:44
  • There is no object Qt_5_PRIVATE_API in version 5.11.3, but usually is in version 5.9.6 . .... Solution : export LD_LIBRARY_PATH=/opt/zoom:$LD_LIBRARY_PATH && /opt/zoom/zoom Commented Mar 29, 2020 at 10:53
  • That solved it! I'll leave question up to help others - if you post as an answer I can also accept solution
    – TSG
    Commented Mar 30, 2020 at 0:22

2 Answers 2


On Fedora I had the same issue when installing the Private Internet Access client UI. I resolved it by updating LD_LIBRARY_PATH before running the client, like so:

user$ export LD_LIBRARY_PATH=/opt/piavpn/lib:${LD_LIBRARY_PATH} && nohup /opt/piavpn/bin/pia-client &

But actually, this work-around isn't exclusive to Fedora or to Private Internet Access. In general, you can try it when you encounter the OPs issue in other circumstances.

In summary, here's the wrapper script that I use (simple), along with a few comments for myself:

# ===============================================================
# NOTE: The PIA VPN GUI client will download an update to:
#       /opt/piavpn/var/update/pia-linux-w.x.z-NNNN.run
# ===============================================================
# To install an update, you must run the above bash(1) script
# as yourself (e.g. "jdoe"), NOT as user "root":
# ===============================================================
export LD_LIBRARY_PATH=/opt/piavpn/lib:${LD_LIBRARY_PATH} && \
       nohup /opt/piavpn/bin/pia-client > /dev/null &
# ===============================================================

I hope this helps.


Encountered this issue when attempting to run TortoiseHg, specifically version 6.5.1 on Rocky 8. Had performed the following steps prior to the issue:

  • Extracted the tortoisehg-6.5.1 tar ball.
  • Installed necessary python 3.9 packages by running sudo yum install python39 and sudo yum install python39-devel .
  • Updated alternatives to the newer python with commands sudo alternatives --config python3 and sudo alternatives --config python and selecting python3.9 in both cases.
  • Updated pip3 by running command sudo pip3 install --upgrade pip.
  • Installed various python dependencies with sudo pip3 install and individually installed mercurial, PyQt5, QScintilla, and iniparse.

The issue arose because installing PyQt5 without specifying a version installed version 5.15.10 that was not compatible with tortoisehg6.5.1, whereas version 5.15.9 was compatible. Running sudo pip3 uninstall PyQt5 followed by sudo pip3 install PyQt5==5.15.9 allowed the command thg to properly open the tortoisehg GUI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .