4

I cannot connect to my Fedora 31 Workstation GUI via "Screen Sharing" from any other (non-Linux) machine. I am almost certain this is due to the encryption that the VNC server for "Screen Sharing" is using. However, I am behind the firewall on my LAN and do not need external access whatsoever, so I do not need encryption. I know for sure that SS does work because when I test it from my Ubuntu machine with Remmina, it works as expected. However, I tested all of these VNC clients on Win/Mac and they do not work:

  • uVNC client
  • RealVNC Viewer (aka VNC Connect)
  • Default "Screen Sharing.app" on macOS

How can I disable the encryption that the "Screen Sharing" VNC server uses so that I can connect from a Windows or Mac machine?

EDIT: The solutions here worked to allow VNC to connect!
gsettings set org.gnome.desktop.remote-desktop.vnc encryption "['none']"
sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload
sudo reboot now

However, the screen resolution is strange and tripled - any how to fix this? enter image description here

14
  • 1
    Does the gsettings solution described here work? ask.fedoraproject.org/t/fedora-30-silverblue-screen-sharing/… (NB the one marked as a solution in that thread, not the earlier one).
    – timday
    Mar 29 '20 at 23:09
  • 1
    Ugh. Is it the same with all clients? Maybe something to do with low-level device-driver stuff, VNC making assumptions about the layout of the framebuffer in memory or something. That sort of thing is why I never liked actual screen-scraping VNC... I always use tigervncserver to host a virtual desktop for remote access. Works great... but you don't get HW accleration, just SW OpenGL.
    – timday
    Mar 30 '20 at 11:57
  • 1
    A wild guess is this is something to do with your desktop's framebuffer being 24bit (the fact you see it repeated 3 times is suggestive). Might be worth trying to coax it into into being 32bit. There's some ancient history with VNC not dealing with 24 bit framebuffers (I'd have thought it had been fixed by now, but maybe not) e.g vnc-list.realvnc.narkive.com/eTZMgdTX/… & bugzilla.redhat.com/show_bug.cgi?id=200474
    – timday
    Mar 30 '20 at 14:08
  • 1
    It's OK I'm not a rep-chasing bounty-hunter these days. Just happy to point someone in what turned out to be kind-of partly the right direction. Better if you write up your own answer of what worked (then maybe extend it if you ever figure out the resolution thing).
    – timday
    Apr 2 '20 at 22:28
  • 1
    @timday, got it working! Changing the display from an odd zoom percentage (150%) to just 100% got VNC working normally. Your answer was my fix! If you'd like to post it, please do and I'll accept, or I will post it as BA if you'd like. :) Thanks again!! Apr 15 '20 at 0:56
2

Running these commands disabled VNC encryption and allows the connection to work on Fedora 31:

gsettings set org.gnome.desktop.remote-desktop.vnc encryption "['none']"
sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload
#finally, reboot the machine/VM
sudo reboot now

2
  • 2
    Please note that it's only the first line that is needed. No need to modify firewall or to reboot simply to change the encryption settings. May 17 '21 at 1:50
  • Good to know, thank you Dec 10 '21 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.