1

Below is the script I have that generates 180320.tar file

cat Bckup.sh
tar -X ./exclude.txt -cf /backup/180320.tar ./1043
gzip /backup/180320.tar

While this script was running, I force deleted the 180320.tar file.

After three days, I still see these processes running and I'm not able to kill them.

ps -ef | grep 180320.tar | grep -v grep
  user1 19923182        1   0   Mar 18      -  0:01 gzip /backup/180320.tar
  user1  6619518        1   0   Mar 18      -  0:01 tar -X ./exclude.txt -cvf /backup/180320.tar ./10203
  user1 14811460        1   0   Mar 18      -  0:01 gzip /backup/180320.tar
  user1 21758806        1   0   Mar 18      -  0:01 gzip /backup/180320.tar

I tried killing them:

kill -9 19923182     6619518        14811460        21758806        

The kill command succeeds, but the ps command continues to show these processes.

When I tried the truss command it failed like below:

truss -p 6619518
truss: 0915-023 Cannot control process #6619518.

Also, the fd folder does not have these processes:

cd /proc/fd/6619518
ksh: /proc/fd/6619518:  not found.

I understand these could be zombie processes but can I get rid of them without a system reboot?

Can you please suggest how can I get the ps command not to show these processes as running? Maybe the ps command is caching old data?

  • Did you run the script, or any of the processes, as root? – Jeff Schaller Mar 27 at 12:56
  • Instead of /proc/fd/6619518 try /proc/6619518 – Lorinczy Zsigmond Mar 28 at 5:05
  • The process was run as a non-root user. – Ashar Mar 28 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.