0

I cant find the libnss3.so file (64bit version) in CentOS 8 even after installing the associated package nss-3.44.0-4.el7.x86_64.rpm.

I can only find the 32 bit version in /usr/lib/ but no 64bit version in /usr/lib64/.

I have tried reverting back to CentOS 7 and verifying that libnss3.so is located in /usr/lib64 and sure enough the file is present in /usr/lib64 in CentOs 7.

Where is 64bit libnss3.so in CentOs 8?

Any pointers/advice/insight would be very much appreciated thanks.

UPDATE I have just done a fresh install of CentOS 8, but still no libnss3.so in /usr/lib64/.

[test@centos-s-1vcpu-1gb-fra1-01 lib64]#sudo cat /etc/*release*
CentOS Linux release 8.1.1911 (Core) 
Derived from Red Hat Enterprise Linux 8.1 (Source)
NAME="CentOS Linux"
VERSION="8 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="8"
PLATFORM_ID="platform:el8"
PRETTY_NAME="CentOS Linux 8 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:8"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-8"
CENTOS_MANTISBT_PROJECT_VERSION="8"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="8"

CentOS Linux release 8.1.1911 (Core) CentOS Linux release 8.1.1911 (Core) cpe:/o:centos:centos:8

[test@centos-s-1vcpu-1gb-fra1-01 lib64]#sudo  ls libnss
libnssckbi.so           libnss_compat.so.2      libnss_dns.so.2         libnss_files.so.2       libnss_resolve.so.2     libnss_systemd.so.2
libnss_compat-2.28.so   libnss_dns-2.28.so      libnss_files-2.28.so    libnss_myhostname.so.2  libnss_sss.so.2         

Also after doing a little more digging it seems as though yum in CentOS 8 only offers i686 versions (32bit) of libnss3.so

[test@centos-s-1vcpu-1gb-fra1-01 lib64]#sudo yum whatprovides libnss3.so
Last metadata expiration check: 0:30:41 ago on Fri 27 Mar 2020 13:38:16 UTC.
nss-3.44.0-8.el8.i686 : Network Security Services
Repo        : AppStream
Matched from:
Provide    : libnss3.so

nss-3.44.0-9.el8_1.i686 : Network Security Services
Repo        : AppStream
Matched from:
Provide    : libnss3.so

Any way i can possibly manually install libnss3.so 64bit?

9
  • If, by the title of your question, you are trying to find it with locate right after you install it, then you won't find it until the mlocate database is updated by the system or until you do it manually with updatedb. Do you find it when you run ls -l /usr/lib64/libnss3.so or rpm -ql nss? Commented Mar 26, 2020 at 21:12
  • A random CentOS 8.1.1911 install : $ cd /usr/lib64/ && ls libnss3.so : libnss3.so .... $ rpm -qf ./libnss3.so : nss-3.44.0-9.el8_1.x86_64 ... .... Why have you got an EL7 package ? ? Commented Mar 27, 2020 at 4:31
  • @NasirRiley My mlocate database is up to date. libnss3.so is just not available as 64bit version on my machine. I have the 32bit version in /usr/lib/ but nothing in lib64. I'm running a fresh re-install of CentOS to see if that makes any difference. Commented Mar 27, 2020 at 13:57
  • @LawlessLeopard Did you run any of the commands that I mentioned above? That package and libnss3-so are there at installation of CentOS 8. Why did you install a CentOS 7 package in your CentOS 8 system? Commented Mar 27, 2020 at 14:01
  • 1
    The package manager in CentOS 8 is dnf. ... 'yum' is the old version, not supposed to be used. ... nss : # dnf install nss.x86_64 Commented Mar 27, 2020 at 18:51

1 Answer 1

0

I have managed to figure out how to install the 64bit version. Although i still do not understand the mechanics of why this works as it does. If anybody knows please let me know I would love to understand why this works as it does.

When installing libnss3.so the 64bit version only installs if I use dnf, when I use yum, it will only install the 32bit version. I figured this out by searching online while I was trying to manually download the package binarys to unpack them myself (see centos.pkgs.org).

I just do not understand why dnf installs a 64bit version while yum installs a 32bit version? Any insight here would be very much appreciated. Anyways thanks to all that have given their input.

2
  • 2
    Unless you have something in /etc/yum.conf, there is no reason that yum will install only i686 packages. I have several CentOS 8 and RHEL 8 machines and yum installs x86_64 packages by default. Commented Mar 27, 2020 at 16:00
  • @NasirRiley Is correct, in fact on CentOS 8, yum is just an alias to dnf, so they are the same exact thing. What provides also only told me about the 32-bit or i386 package, but a search revealed that there was a 64-bit package. All you need to do is run sudo dnf install nss.x86_64 Commented Aug 10, 2020 at 6:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .