0

I recently moved to Microsoft's Windows 10 because of some apps that wine wouldn't run. I consider myself a fairly knowledgeable Gnu/Linux user. I am trying to set up a dual-boot with windows 10 and solus. These are the steps I followed:

  1. I shrank the C:\ partition of the drive, to allow space for Gnu/Linux. (The new partition had 160 gigs).
  2. I created a bootable Solus USB with balenaEtcher.
  3. I restarted my computer, pressed f2 to enter the BIOS, and selected the USB as the first boot option. I applied these settings and the computer automatically restarted and booted into the live Solus.
  4. I went into the KDEPartition Manager, and formatted the 160gb partition into ext4.
  5. I applied this, restarted the computer, and started the Installation Manager
  6. Upon reaching the "Where should we install?" menu, I selected the "custom" option.
  7. I selected my 160gb volume to be the "/". This may be wrong. I have never installed using the custom menu. I might have need to choose this to be "/home", but no tutorials mentioned this. Also, the 160gb volume showed up as 170gb.
  8. I spammed through the rest of the options, such as username/passwd.
  9. I restarted the computer, removing the USB.
  10. The computer booted into Windows 10.
  11. I though it might be a boot order issue, so I checked the BIOS. There was no Gnu/Linux option. There were 3 Windows options, but that is the way my computer has been for a while, even when using Gnu/Linux. nevertheless, I tried each of them, but all of them predictably booted into Windows.
  12. I got a new installation USB with a new iso and tried steps 2-9 again. 10 and 11 were the results, again.
  13. I entered Windows' partition manager to see what's what, and windows had replaced that new partition with the drive letter D:\

I am not sure why this is doing this. I am on a Dell Precision Tower 3420, which originally had Windows 10 pre-installed. The default barracuda HHD was too slow, so i used a 120gb SSD with Ubuntu instead. I bought a 500gb m.2 SSD and transfered the old SSD to the m.2. I needed Windows, so I cloned the original HHD to the m.2, wiping Gnu/Linux. Then I tried the aforementioned steps. I do not want to use a VM, so please do not include answers involving that. Much thanks in advance!

3
  • Step 8, at the end of the installation process, grub may ask if it should install to /dev/sda or /dev/sdaX` (where X is a digit in the range 1-9). The default on Debian is /dev/sdaX but it should be /dev/sda.
    – roaima
    Mar 25 '20 at 20:38
  • 1
    "Also, the 160gb volume showed up as 170gb". That's because you're misusing the units. There is no such thing as "gb", only "Gb" (gigabit), "GB" (gigabyte), or "GiB" (gibibyte - yes, really). GB is based on powers of 10, GiB is based on powers of 2; for large-ish values they're significantly different. To add to the confusion some technologies use GB when they mean GiB.
    – roaima
    Mar 25 '20 at 20:41
  • @roaima Sorry. I was not aware of that. I just saw a GB, or maybe a gb after the units, so that is what I wrote down. Mar 26 '20 at 21:20
1

Correct, you only have to define root partition for "/" and maybe swap. Also standard install recommendation is Linux first then all others. Also you are selecting for format in EXT4 for "/"? Grub should be installed to which ever drive is set as 1st boot drive in your BIOS.

I made a mistake like @roalma mentioned. I think I rebooted while holding down the Shift or ESC key and was able to view grub boot option.
Once you get back into Edit sudo nano /etc/default/grub and after you save sudo update-grub but I'm sure you knew that part.

You also might have assigned the USB drive for grub install.

1
  • Yes, I did on accident. Thanks so much, and sorry for asking a question with an answer I could find if I tried hard enough. Apr 12 '20 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.