10

I've got a Bluetooth headset (Sony WH-1000XM3) which works perfectly with PulseAudio as long as I only use it as an output device. Changing the Bluetooth profile in pavucontrol works for everything (SBC, LDAC, aptX HD, aptX and AAC) except HSP/HFP. PulseAudio outputs the following error when this happens:

I: [pulseaudio] protocol-native.c: Application "PulseAudio-Lautstärkeregler" requests card profile change. card = bluez_card.38_18_4C_6D_C9_22, profile = headset_head_unit
I: [pulseaudio] core.c: default_sink: bluez_sink.38_18_4C_6D_C9_22.a2dp_sink -> alsa_output.usb-BEHRINGER_UMC204HD_192k-00.analog-surround-40
I: [pulseaudio] source-output.c: Freeing output 3 "Ausschlagsserkennung"
I: [bluetooth] bluez5-util.c: Transport /org/bluez/hci0/dev_38_18_4C_6D_C9_22/sep5/fd13 released
I: [pulseaudio] sink.c: Freeing sink 1 "bluez_sink.38_18_4C_6D_C9_22.a2dp_sink"
I: [pulseaudio] source.c: Freeing source 3 "bluez_sink.38_18_4C_6D_C9_22.a2dp_sink.monitor"
I: [pulseaudio] backend-native.c: doing connect
E: [pulseaudio] backend-native.c: connect(): Function not implemented

On start also

E: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

appears in the log.

I'm on Fedora 31 and have the following package versions

Installed Packages
NetworkManager-bluetooth.x86_64              1:1.20.10-1.fc31                    @updates               
bluecurve-cursor-theme.noarch                8.0.2-21.fc31                       @fedora                
bluecurve-icon-theme.noarch                  8.0.2-21.fc31                       @fedora                
blueman.x86_64                               1:2.1.2-1.fc31                      @updates               
bluez-cups.x86_64                            5.54-1.fc31                         @updates               
bluez-libs.x86_64                            5.54-1.fc31                         @updates               
bluez-obexd.x86_64                           5.54-1.fc31                         @updates               
bluez-tools.x86_64                           0.2.0-0.11.git20170912.7cb788c.fc31 @fedora                
bluez.x86_64                                 5.54-1.fc31                         @updates               
gnome-bluetooth-libs.x86_64                  1:3.34.1-1.fc31                     @updates               
gnome-bluetooth.x86_64                       1:3.34.1-1.fc31                     @updates               
pulseaudio-libs-devel.x86_64                 13.99.1-2.fc31 @updates               
pulseaudio-libs-glib2.x86_64                 13.99.1-2.fc31 @updates               
pulseaudio-libs.i686                         13.99.1-2.fc31 @updates               
pulseaudio-libs.x86_64                       13.99.1-2.fc31 @updates               
pulseaudio-module-bluetooth-freeworld.x86_64 1.3-4.fc31     @rpmfusion-free-updates
pulseaudio-module-gsettings.x86_64           13.99.1-2.fc31 @updates               
pulseaudio-module-jack.x86_64                13.99.1-2.fc31 @updates               
pulseaudio-module-x11.x86_64                 13.99.1-2.fc31 @updates               
pulseaudio-utils.x86_64                      13.99.1-2.fc31 @updates               
pulseaudio.x86_64                            13.99.1-2.fc31 @updates

My bluetooth device

Bus 001 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

EDIT: No news, yet (ordered a new dongle, but that one has exactly the same ID and name), but this thread reports the same for Ubuntu.

17
  • Just to clarify, when you change your output configuration to "Headset Head Unit (HSP/HFP)" is when you get issues correct? I have your setup and I had issues until I did the update to the most recent Sony's Firmware version. From time to time, I need to remove the device from the Bluetooth devices, to be able to connect again correctly. – Nuno Dio Mar 24 '20 at 21:49
  • Exactly. I'm on the latest update, I just checked, but thanks for the suggestion, woudn't have thought of that! Removing and reconnecting doesn't help ... with "connect again correctly" you mean getting a connection at all? Or the same problem as mine? – Daniel Hauck Mar 24 '20 at 22:47
  • It's simply going to Settings>Bluetooth>Click on the WH-1000 Device> Click on Red Button "Remove Device" then, Disable Bluetooth> Enable Bluetooth > Connect to WH-1000 Device. I know this is not a very advanced solution, but sometimes when I got weird behavior I do this and it comes back to normal. Just to mention... I just realized that you have installed the package pulseaudio-module-bluetooth-freeworld.x86_64 1.3-4.fc31 @rpmfusion-free-update Do you really need this? I don't use anything from rpmfusion at all. – Nuno Dio Mar 24 '20 at 23:05
  • That's would I did, but it didn't change anything. I need pulseaudio-module-bluetooth-freeworld for the LDAC, aptX etc. support. – Daniel Hauck Mar 24 '20 at 23:23
  • I just tried without this package and the normal pulseaudio-module-bluetooth instead, but this led to exactly the same behaviour. – Daniel Hauck Mar 24 '20 at 23:25
1

I have a USB Bluetooth dongle that uses the same chipset and was able to get it working on Raspbian buster. A2DP support seems to be pretty good out of the box, but you need HSP/HFP support if you are using a headset. The following link states something like this:

https://hackaday.io/project/165208-an-old-rotary-phone-as-bluetooth-set/log/162491-setting-up-the-bluetooth

Furthermore, if you find that your headset supports the HFP profile, you will need to install Ofono, as stated in the PulseAudio documentation following:

https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Bluetooth/

I've generalized the scripts that I have, and have posted a link to the GitHub repo:

https://github.com/lmandres/RaspbianBluetoothScripts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.