1

I freshly installed system on my HW RAID 0 drives, over which is installed SW Raid 1 with LVM. After Installation of Debian 10, I've got this problem which I don't know how to resolve. enter image description here

I tried so far, completly wipe drives, create own LVM in live image, which worked, tryed to force new UUID. Nothing worked.

0

If your system uses UEFI, then access the EFI System Partition (ESP) using a live boot media or whatever. It is normally a small FAT32 partition. Once you have it mounted somewhere, you'll find a tiny GRUB configuration file at <mountpoint>/EFI/debian/grub.cfg. It is actually just a reference to the location of the actual GRUB configuration file. On my system, where /boot is a normal GPT partition (not within LVM), the file looks like this:

search.fs_uuid 1406433d-b809-4e38-adea-94f1b95ae313 root 
set prefix=($root)'/grub'
configfile $prefix/grub.cfg

On your system, the first line is probably different and mentions the (now obsolete) LVM ID. Make sure that it correctly references the filesystem that contains your /boot/grub directory; even though it mentions root, it does not necessarily mean the root filesystem of the Linux OS, but just the root of the GRUB's directory structure, which may be a part of the root filesystem or a separate /boot filesystem.

0

in the end, I buildet RAID 1 with HW raid, and created LVM.

Seems like the HW RAID did not liked solution with two raid 0, and over them one raid 1 with LVM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.