0

I believe I have done everything all the manuals have said to get this to work, and have been struggling with it for a few days now. Here are the details of the setup:

Host: Linux Mint 18.1 Serena, Ubuntu 5.4.0-6ubuntu1~16.04.4, 4.4.0-53-generic

Guest: Debian GNU/Linux 10 (buster), 4.19.0-8-amd64

Virtualbox version: 5.1.38_Ubuntu

Guest Editions version: 5.1.38

Guest Editions is installed in the guest, my user is part of the group vboxsf, in the gui of Virtualbox on the host, I selected a folder in the host home directory which I made called MintDebianSharedFolder and selected Auto-Mount, and gave the name to be seen by the guest MintDebianSharedFolder5. Now upon booting the guest (Debian 10):

cardamom@ruthenium:~$ sudo ls -la /media/
insgesamt 14
drwxr-xr-x  4 root root   4096 Mär 24 12:41 .
drwxr-xr-x 19 root root   4096 Mär 23 14:34 ..
lrwxrwxrwx  1 root root      6 Mär 23 13:19 cdrom -> cdrom0
dr-xr-xr-x  6 root root   2048 Mai  9  2018 cdrom0
drwxrwx---  2 root vboxsf 4096 Mär 24 12:38 sf_MintDebianSharedFolder5
cardamom@ruthenium:~$ sudo ls -la /media/sf_MintDebianSharedFolder5/
insgesamt 8
drwxrwx--- 2 root vboxsf 4096 Mär 24 12:38 .
drwxr-xr-x 4 root root   4096 Mär 24 12:41 ..

There are in fact 2 files in the corresponding folder on the host - Why are they not showing up in the guest?

I created the second one just a moment ago on the host, but it is just not visible in the guest.

Here is the output of a few other commands on the Debian 10 guest which may help diagnose:

cardamom@ruthenium:~$ df
Dateisystem    1K-Blöcke Benutzt Verfügbar Verw% Eingehängt auf
udev             3354284       0   3354284    0% /dev
tmpfs             674824    9084    665740    2% /run
/dev/sda1        7578488 5697972   1475832   80% /
tmpfs            3374108       0   3374108    0% /dev/shm
tmpfs               5120       4      5116    1% /run/lock
tmpfs            3374108       0   3374108    0% /sys/fs/cgroup
tmpfs             674820      20    674800    1% /run/user/1000
/dev/sr0           58214   58214         0  100% /media/cdrom0
cardamom@ruthenium:~$ mount | grep sf
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

cardamom@ruthenium:~$ sudo VBoxControl guestproperty get /VirtualBox/GuestAdd/SharedFolders/MountDir
Oracle VM VirtualBox Guest Additions Command Line Management Interface Version 5.1.38
(C) 2008-2018 Oracle Corporation
All rights reserved.

No value set!
cardamom@ruthenium:~$ lsmod | grep vboxguest
vboxguest             299008  4
cardamom@ruthenium:~$ cd /opt/VBoxGuestAdditions-*/init 
cardamom@ruthenium:/opt/VBoxGuestAdditions-5.1.38/init$ ls
vboxadd  vboxadd-service  vboxadd-x11
cardamom@ruthenium:/opt/VBoxGuestAdditions-5.1.38/init$ sudo ./vboxadd setup
vboxadd.sh: failed: Look at /var/log/vboxadd-install.log to find out what went wrong.
vboxadd.sh: Starting the VirtualBox Guest Additions.
vboxadd.sh: failed: modprobe vboxsf failed.

Any ideas much appreciated

1
0

Meanwhile, I have fixed it, after updating Linux Mint and Virtualbox on the host and Guest Editions on the guest, it just worked. The new details are:

Host: Linux Mint Linux Mint 19.3 Tricia, Ubuntu 7.4.0-1ubuntu1~18.04.1, 5.0.0-32-generic

Virtualbox version: 5.2.34_Ubuntu

Guest Editions version: 5.2.34

The shared folder in the guest Debian 10 now actually contains the files which are in the shared folder on the host.

One of the answers somewhere on stackexchange mentioned that Virtualbox may not 'play nicely' with slightly older Linux so decided to upgrade the host's system. After the upgrade from 18.1 to 19.3 the software centre allowed the newer Virtualbox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.