0

I have been using VeraCrypt for a while now and it seems good. I have a large encrypted disk image that is stored on an external hard drive. I use VeraCrypt on my 2017 MBP running macOS 10.14, and haven’t had a problem with it before.

However, today I mounted the disk image in VeraCrypt. It was working fine. I then tried to drag a folder into the trash using Apple’s default DE and it removed everything. But upon unmounting the disk image, it wouldn’t allow me to remount the image. I then restarted my computer as it was going very slowly (both VeraCrypt and the DE), and now VeraCrypt would not open. I even reinstalled it using homebrew cask’s zap command, but it still didn’t open. I even tried restarting it again and running.

/Applications/VeraCrypt.app/Contents/macOS/VeraCrypt

It would indeed open VeraCrypt — however, it was now saying that hdiutil could not mount the disk image.

I assumed that maybe I had corrupted it, so I plugged in the hard drive to my Linux machine and mounted it. It worked fine, just as usual, and I could see all of my data, so I am no longer worried about having corrupted it.

My question is: does anyone know what product of macOS might be causing this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.