0

Currently I have a tunnel setup with my work Linux box (remote machine) and my macbook at home (local machine). Jira and other tools can only be accessed through our intranet so I'd like to use SOCKS to proxy my web browser traffic using firefox and my tunnel.

On my remote machine I route traffic through port 43022 and then to port 22 on my local network.

ssh -R 43022:localhost:22 home@home_external_ip

At home I access the remote machine using that port.

ssh work.username@localhost -p 43022

How can I set this up to allow proxying through a web browser?

ssh -D 43022 work.username@localhost

ran from my local machine gives me a password prompt for what I assume is the root user which I do not have access to. Only my own account on the remote machine.

0

Though it seems technically good this may be problematic to the security of the network your proxy has access to which may cost you your job, reputation, money and freedom.

Assuming written permission: Try using verbose logging and/or substitute the remote server with other systems you can control and monitor the logs .

https://www.tecmint.com/enable-debugging-mode-in-ssh/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.