1

I'm running Kali from VMware. I upgraded my Kali, and after rebooting I can't login. When I restart I'm login automatically via tty1 , and receiving the following error:

uname : loadlocale.c:129 : _nl_inter_locale_data : Asserting 'cnt<(sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed
/bin/uname failed caught signal 6

I tried to login in recovery mode, and received, what seems to be, the same failed error:

intel_rapl: no valid rapl domains found in package 0
echo: loadlocale.c : 129: _nl_inter_locale_data : Asserting 'cnt<(sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed

I saw a few solutions for these problem but they are all executed from the command prompt. I tried reaching it by editing the login command using 'e' in the login window, but i got the same failed message. I tried running the same commands in the GNU GRUB command line using 'c' when login, but nothing seems to work. right now i can't login or reach the command prompt in any whey

3
  • 1
    thank for the respond, i edited it Commented Mar 23, 2020 at 12:19
  • I can't speak for the problem with logging in, but if you are stuck getting to a command prompt have you tried opening one of the other terminals. Try pressing ctrl-alt-F5 (or any of F1 to F9). Usually your GUI is on 1 or 2. Give it a few seconds after trying each, it can take a moment to switch out of the GUI. Commented Mar 23, 2020 at 12:23
  • unfortunately it does nothing when i'm in the GUI Commented Mar 23, 2020 at 14:05

1 Answer 1

1

It looks like the locale data files (= the files defining date&time formats, command message translations etc.) are corrupted somehow.

Because those files are being used by just about every command, most commands will produce similar error messages. The internationalization libraries that use those files would probably handle the lack of locale files by falling back to standard POSIX formats and US English messages, but it seems that corrupted locale files are causing the libraries to fail, causing the commands to crash without doing anything useful.

You might try accessing your system using some Linux Live CD or similar boot media. Once you gain access to the filesystem of the Kali installation, you should try and find the /usr/lib/locale/locale-archive file.

(When using a Live CD, it will probably require you to mount the filesystem of the installed OS to some mountpoint first, and then you'll need to prefix the mountpoint path to the file pathname. For example, if you mount the Kali root filesystem to /mnt, the full path to the corrupted file will be /mnt/usr/lib/locale/locale-archive.)

Once you find the correct file, rename it to something else (for example, locale-archive.broken). This might allow the Kali installation to boot (although with a strict POSIX/US English localization).

Once you get your system up and running, and have verified that you aren't running out of disk space, you might then use the locale-gen command to regenerate the locale-archive file.

If that causes the problem to re-occur, delete/rename the locale-archive file again using a Live CD, then return to the normal OS and run apt reinstall locales and apt reinstall util-linux-locales to refresh the source files used to generate the locale-archive file (as those source files might be corrupted too), and then try locale-gen again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .