Probably its typical issue, but I couldn’t found the answer. Sometime ago I had mini-ITX server worked on ZOTAC IONITX-G-E. It was managed by Ubuntu 10.10. I setuped Gigabit network with this server. I installed one additional network card (Planet ENW-9700. It's PCI-E x1 card) because it did some routing, that's why I need two network cards. I used DGS-1005D as Gigabit switch. It worked fine, Planet network card had Gigabit network connection. When I used it, network speed was ~40-50Mb\s.

After that a month ago I decided to do upgrade, because that system wasn't enough for me. I bought new Asus P8H77-I motherboard with Intel i3-3225. I installed it in the same box instead of Zotac motherboard and installed Ubuntu Desktop 12.10. But somehow network card doesn't work as Gigabit connection. Distance between server and switch is 6-7 meters.

I googled for it, and found some similar topics for Realtek NIC(this motherboard uses Realtek 8111F). So, based on some manuals I download latest Realtek drivers from this page, compiled them and installed. I disabled previous one RTL8169 driver that used before. But after that there is no Gigabit connection. I tried to force it by

sudo ethtool -s eth0 speed 1000 duplex full autoneg on

but it didn't do anything. Connection speed remained 100Mb\s. Here is ethtool eth0 output

 Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                           drv probe ifdown ifup
    Link detected: yes

Could you please suggest anything?

I have the last option to install Planet NIC PCI-E x1 into PCI-E x16 slot and use it as before, but I don't want to occupy the only one PCI-E slot

  • 1
    Just some basics: Same cable used as before? (And it does have all 8 wires wired up?) I've had some lightning-caused problems with a D-Link Gigabit switch where ports would only operate at 10Mbps... You might also want to try a live CD (say a Windows 7 install CD to see if it depends on the booted OS, which might help narrow down the problem between hardware and drivers...) Dec 3, 2012 at 6:57
  • Yes, I used the same cable. I didn't do anything with it and with switch. They are remain the same. I'll try LiveCD, thanks Dec 3, 2012 at 10:19

1 Answer 1


I tried LiveCD and it was the same - 100Mb. I tried to install side by side Windows 7, and after that installed drivers for network card from ASUS site. Network started to work, but network speed was 100Mb.

Then I installed my old Planet NIC and it started work as 1000Mb, and real transfer speed is 50-70Mb/s. So, I'm not sure about reason of it.. Maybe issue is in network cable and builtin NIC couldn't work on high speed. And somehow external card works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.