0

So the problem is the following. I have to work from home due to isolation, and I need to remote control my desktop computer in my office through ssh.

My desktop computer runs ubuntu 18.04, has openssh client and server installed and this is the output of ifconfig (i am including the data i think relevant, x1 and x2 are just placeholders):

docker0: ....
         ....

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.128.67.196  netmask 255.255.0.0  broadcast 10.128.255.255
        .....
        .....  

lo: ....
    ....

To make things more painful my home laptop runs windows 10, so things are even more inconsistent and i cannot use an array of tools available with ubuntu. Now, my uni has an internal network ofc, and with my limited amount of knowledge about networks I did some tests.

-so if I try to connect from a desktop pc internal to the uni (connected by cable) i can just ssh into my pc without too many problem by going:

ssh 10.128.67.196

-I have connected from my desktop to the supercomputer we usually use, which i suppose it will be in a "trusted list" of the uni via: ssh supercomputer_address ->And everything runs fine

-If I ssh into the supercomputer FROM my desktop, I can ping my desktop pc, but i CANNOT ssh back into my desktop, or it prompt the error:

ssh: connect to host 10.128.67.196 port 22: No route to host

Now, I double checked that port 22 is open on my desktop pc, infact if i type:

sudo netstat -lpn |grep :22

I get:

tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1311/sshd           
tcp6       0      0 :::22                   :::*                    LISTEN      1311/sshd

I also doublecheked that it's not a firewall problem, as my firewall is currently disabled If i type : sudo ufw status i get -> Status: Inactive

-If I try to ping my desktop machine from my laptop using putty and :

ping 10.128.67.196

i get -> Request timed out

-If I try to ping my desktop machine from outside the uni network USING CISCO ANYCONNECT WITH MY UNI VPN, or even from a laptop connected to the wifi network of the university, but not connected by cable with:

ping 10.128.67.196

I get -> Request timed out

There has to be something easy that i am ignoring and that is making me crazy, can anyone help please?

8
  • 1
    "I also doublecheked that it's not a firewall problem, as my firewall is currently disabled" Your university network probably has a firewall in place as well. Have you checked with the IT department of your university? – stefan0xC Mar 19 '20 at 7:39
  • Well I submitted a request to check, but they are A) Slow as hell B) Useless most of the times C) They tend not to support ubuntu requested (see B) D) Oberated with work right now cause everybody is trying to set up the remote working because of the virus. If the university has a firewall, wouldn't accessing it through the university VPN take care of the issue? – user3458909 Mar 19 '20 at 7:43
  • Putting in x1 and x2 in the addresses is just annoying, these are RFC1918 addresses so telling up the actual values will make no difference. Almost certainly your university has split the 16million addresses in the 10.0.0.0/8 network into 256 networks with 65k addresses in each. Assuming you are not misleading us we know they use this split for at least one network 10.128.0.0/16 and it would be unusual not to go for the same split for each subnet. So when you connect to the wifi using windows what does ip route tell you? lots of routes including one for 10.128.0.0 or just a very few? – icarus Mar 19 '20 at 8:00
  • Fixed the ip address. I typed ip route on my phone, connected to the wifi, using termius. The output are only 2 lines. If I type it from the office computer they are the following 3: 10.128.0.0/16 dev eno1 proto kernel scope link src 10.128.67.196 metric 100 169.254.0.0/16 dev eno1 scope link metric 1000 172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown – user3458909 Mar 19 '20 at 8:23
  • 1
    There are ways, particularly as @Stefan says if you have ssh access but there are many others. However they will almost certainly be breaking your IT departments terms of use (which will say not to bypass their firewalls). Whilst you are awaiting the response from your IT department, go and install WSL on your windows machine. – icarus Mar 19 '20 at 22:38
0

The desktop machine has an address in the IPv4 10.0.0.0 private address range, it just isn't publicly visible (unless whoever manages NAT for your network sets it up specially). See if you have some sort of VPN access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.