0

I'm using rsync to back up my filesystem to a mounted disk /media/<user>/UbuntuBackups1/.

I want 6 daily backups, 3 weekly backups and 3 monthly backups if possible.

I've read that by default rsync is only supposed to copy new or changed files but that hasn't been my experience. I also want the files accessible from a Windows machine if possible and I have reviewed the man pages and several questions across the web.

I've tried swapping the t flag for the c flag. I've tried omitting -a and adding the included options manually. Every time I run my scripts it copies everything again.

Flags last tested were checksums only, verbose, recurse into directories, ownership, groups, permissions.

It also has on at least one occasion, copied all the exclusions as well.

I'm putting scripts in cron.daily and cron.weekly if that makes a difference.

rsync -cvrogp --links --exclude=/dev --exclude=/mnt --exclude=/media --exclude=/tmp --exclude=/lost+found --exclude=/emby --exclude=/cloud --exclude=/home/_myuser_/.cache --exclude=/proc --exclude=/run --exclude=/sys / /media/_myuser_/UbuntuBackups1/daily

I see I can use logrotate for handling the versions so nvm that we'll just stick to rsync for now.

  • What filesystem is used in /media/_myuser_/UbuntuBackups1/daily? – Arkadiusz Drabczyk Mar 19 at 0:26
  • Add the -i flag and you'll get additional output. Add a few lines of it to your question. – BowlOfRed Mar 19 at 0:28
  • @ArkadiuszDrabczyk fuseblk is the fstype reported by df -Th – Jeffrey Becker Mar 19 at 1:13
  • @BowlOfRed .f...p..... lib/modules/4.15.0-88-generic/kernel/drivers/media/i2c/vp27smpx.ko .f...p..... lib/modules/4.15.0-88-generic/kernel/drivers/media/i2c/vpx3220.ko .f...p..... lib/modules/4.15.0-88-generic/kernel/drivers/media/i2c/wm8739.ko .f...p..... lib/modules/4.15.0-88-generic/kernel/drivers/media/i2c/wm8775.ko – Jeffrey Becker Mar 19 at 1:16
  • @JeffreyBecker: fuseblk is NTFS AFAIK, that may be the reason. Check if your rsync command works correctly by using it on non-NTFS filesystem, ext3 or something. You can for example create a temporary directory in /tmp, say /tmp/rsync, create several files there touch a b c d, create a new directory /tm/rsync-test in which you could try to mirror /tmp/rsync. Run rsync again, then create new files in /tmp/rsync and check if only new files are copied. It should work. – Arkadiusz Drabczyk Mar 19 at 1:20
0

Your string is saying that the permissions are not matched between the copies. It's not copying the file, but it is trying to reset the permissions.

As your destination is NTFS, the permssions are probably not mapped identically. You might want to try --no-perms

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.