1

I'm trying to use the proprietary nvidia driver on a gigabyte Aero 15Xv8 laptop running Fedora 31. The nivdia driver installs fine (from RPM fusion) and it shows up fine in nvidia-settings too. But somehow it does not get used:

  • glmark2 only shows the Intel integrated GPU. and if I run glmark2 with DRI_PRIME=1, it complains about failed to load driver: nouveau before falling back to the Intel GPU.
  • nvidia-settings has an entry for the GPU but no entry for the display itself, cf screenshot below

any suggestion as to where I should look ?

screenshot of nvidia-settings with a GPU but no screen

4
  • Did you follow all the appropriate steps at RPM Fusion's Howto/NVIDIA?
    – rickhg12hs
    Commented Mar 18, 2020 at 4:55
  • yes, step by step: add rpm-fusion repos, then use lspci to verify we have two GPUs, disable secure boot in bios, install driver (modinfo shows correct version), make sure that "nouveau" is blacklisted and uninstalled, check the nvidia-drm.modeset=1 in lernel args, check that I have x11 and not wayland, etc
    – Gyom
    Commented Mar 18, 2020 at 13:19
  • also I tried copying the nvidia.conf into /etc/X11/xorg.conf.d but it made no visible change.
    – Gyom
    Commented Mar 18, 2020 at 13:22
  • solved ! I realized I could post my problem on askfedora, and indeed I found they have similar questions there. One answer ask.fedoraproject.org/t/4204/7 happened to just solve my problem. still, thanks.
    – Gyom
    Commented Mar 18, 2020 at 14:07

1 Answer 1

1

I found a solution to my problem somewhere on askfedora: after copying nvidia.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d (as per the RPM fusion howto) one should edit it to add Option "PrimaryGPU" "yes" in the "OutputClass" section.

As a result, /etc/X11/xorg.conf.d/nvidia.conf has:

Section "OutputClass"
        Identifier "nvidia"
        MatchDriver "nvidia-drm"
        Driver "nvidia"
        Option "AllowEmptyInitialConfiguration"
        Option "SLI" "Auto"
        Option "BaseMosaic" "on"
        Option "PrimaryGPU" "yes"
EndSection

Section "ServerLayout"
        Identifier "layout"
        Option "AllowNVIDIAGPUScreens"
EndSection

Life still isn't perfect because I can't switch between the two GPUs, but hey, at least I get decent FPS in games again :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .