1

Every time I restart the system and log in, a password prompt pops up:

Password prompt

In most cases, this happens as soon as I open Chromium (it actually seems to freeze up the browser), and usually clicking on "Cancel" re-opens the prompt several (3-5) more times, which is extremely annoying. What is causing this and how can I disable it? Is there any way to identify the process behind it, e.g. using htop?

Desktop environment is XFCE 4.

  • 2
    Hit continue without adding a password and it will stay away. If you do add a password you need to provide it when this pops up. This is the connecting between your password safe and software that is set for a password. Oh and the one this is likely about is your network connection ie. networkmanager. When you provide a password here no internet unless you provide a password. – Rinzwind Mar 17 at 15:44
  • Thanks, I'll try this – david Mar 18 at 14:41
1

What is causing this?

Answer from the manpages man chromium:

  --password-store=<basic|gnome|kwallet>
          Set  the  password  store to use.  The default is to automatically detect based on the desktop environment.

      basic selects the built in, unencrypted password store.  
      gnome  selects  Gnome  keyring.   
      kwallet  selects (KDE) KWallet.  (Note that KWallet may not work reliably outside KDE.)

How to disable it?

run chromium with: --password-store=basic :

chromium --password-store=basic

You can create and alias :

alias chromium='chromium /usr/share/applications/chromium.desktop'

Then run: chromium from the terminal.

Also you can edit the chromium configuration file:

sudo nano /usr/share/applications/chromium.desktop

Change the following line:

Exec=/usr/bin/chromium %U

to:

Exec=/usr/bin/chromium --password-store=basic %U
| improve this answer | |
  • Thanks, this seems to have solved the issue. Is it possible to block Chromium from saving any password at all? Also, what is the purpose of %U? – david Mar 19 at 10:48
  • @david unix.stackexchange.com/a/55053/153195 – GAD3R Mar 19 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.