2

All of a sudden, Google Chrome stopped working and won't open anymore on my Ubuntu 18.04 Server (which I can't restart). Even after remove and reinstall google-chrome-stable, it still gives the same error:

  • [1553930:1553930:0316/233920.682604:Error:edid_parser.cc(102)] Too short EDID data: manufacturer id
  • [1553964:1553964:0316/233920.967066:Error:viz_main_impl.cc(161) Exiting GPU process due to errors during initialization

Greatly appreciate your help.

1
  • After an update on Ubuntu 16.04 I'm getting the same problem. chromium-browser fails to start, even after reboot. Have you managed to resolve it yet? Apr 7, 2020 at 16:48

1 Answer 1

1

Im running the same problem using Kali Linux in virtual environment. The error Error:edid_parser.cc(102)] Too short EDID data is related to all chromium based apps such as Chromium browser itself, Google Chrome, VS Code, Atom Code Editor, Opera Browser and so on.

This is not an official solution but maybe can throw your error away in the time being. Supposing you want to lauch google chrome you can try this: google-chrome --disable-gpu

2
  • Thanks for your reply, but it doesn't solve the problem. Maybe I shall try to reboot the system, sometimes this simple trick can solve many problems. Thanks again. Have a wonderful day. Mar 23, 2020 at 16:50
  • Wow this is really annoying. Chromium has finally stopped working on my Ubuntu 16.04. It's always been pretty unreliable tbh, with regular hangs and crashes. This time a reboot has not fixed it. I'm now using Firefox, which is sooo slow. Hopefully this Chromium problem will get fixed. Apr 7, 2020 at 19:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .