1

I have a Dell Notebook with Windows 10 installed. I installed debian about 4 months ago making it a dual boot option. Have been using debian daily, everyday it shows me the GRUB and auto loads into debian. Yesterday decided to go into windows, just selected windows in GRUB, now I can't go back into debian.

I shutdown/restart and always loads windows. It doesn't even show me the GRUB. The boot loader first option is debian and the second windows boot manager, nonetheless it doesn't load debian.

Already tried:

  • Manually choosing the debian option in boot loader (f12)
  • Disabled secure boot.
  • Tried windows recovery options > advanced restart
  • Was about to remove windows boot loader from boot options but BIOS didn't allowed me to.

What else can I do?

EDIT: Well, I decided to follow these instructions and now nothing boots anymore, neither debian or windows... This is the command:

bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi

EDIT 2: As requested this is the output of sudo parted --list

user@debian:~$ sudo parted --list
Model: ATA WDC WD10JPVX-75J (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  525MB   524MB   fat32           EFI system partition          boot, esp
 2      525MB   567MB   41.9MB  fat32           Basic data partition          hidden
 3      567MB   701MB   134MB                   Microsoft reserved partition  msftres
 4      701MB   1488MB  786MB   ntfs            Basic data partition          hidden, diag
 5      1488MB  834GB   833GB   ntfs            Basic data partition          msftdata
 8      834GB   846GB   12.0GB  linux-swap(v1)
 9      846GB   991GB   145GB   ext4
 6      991GB   992GB   979MB   ntfs                                          hidden, diag
 7      992GB   1000GB  7892MB  ntfs            Microsoft recovery partition  hidden, diag


Model: Sony Flash Disk (scsi)
Disk /dev/sdb: 16.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.1GB  16.1GB  primary  fat32        boot, lba
  • 1
    can you boot a live sesssion and show sudo parted --list please. – nobody Mar 16 at 17:52
  • @nobody just edited the question with the output. – ZeCarioca Mar 16 at 20:21
1

I would try to redo the GRUB Installation process (if at least grub seems to load, you can skip step 3):

  1. boot from a linux live iso (e.g. debian live iso)
  2. mount your efi system partition: mount /dev/sda1 /mnt
  3. grub needs devices: mount --bind /dev /mnt/dev
  4. chroot into your debian system: chroot /mnt
  5. reinstall grub entry in firmware boot manager: grub-install --target=x86_64-efi --efi-directory=/mnt
  6. let grub detect the installed operating systems (if I remember right grub should output the detected operating systems): grub-mkconfig -o /mnt/grub/grub.cfg

https://fosswire.com/post/2009/05/restoring-overwritten-grub/

| improve this answer | |
  • Since my first edit my windows also stopped working. I imagine reinstalling the GRUB won't change anything for windows, however, just to be sure, it also won't remove/corrupt any windows files/boot data right? – ZeCarioca Mar 16 at 22:18
  • 1
    Grub will of course change boot data, but that is actually what we want, if we have a dual boot setup, because we just want our Firmware to boot Grub and let Grub handle the rest (e.g booting windows or linux). But I can of course not give you a guarantee. – CodingVoid Mar 16 at 22:28
  • Very well, however the command 3 returns grub-install: command not found I'm using a Debian Live session. Btw managed to recover windows by using an ISO. However stll no debian... – ZeCarioca Mar 17 at 0:01
  • Got it, I used this tutorial fosswire.com/post/2009/05/restoring-overwritten-grub and the last command didn't worked so I used your command 3. Please include this link in your answer so I can accept it! Thanks a lot. – ZeCarioca Mar 17 at 1:28
  • I forgot the chroot... my bad sorry. – CodingVoid Mar 17 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.