1

I'm just following the LFS book and when I reach the point to install GLibc the second time, in the chroot, it builds fine, but when I run make install, it errors. It installs a file to /usr/share/i18n/charmaps, but then proceeds to try and gzip it and it can't find it (at least that's what I think its doing).

The last 30ish lines of the log:

/usr/bin/install -c -m 644 /sources/glibc-2.31/build/gnu/lib-names-64.h /usr/include/gnu/lib-names-64.h
/usr/bin/install -c /sources/glibc-2.31/build/iconv/iconvconfig /usr/sbin/iconvconfig.new
mv -f /usr/sbin/iconvconfig.new /usr/sbin/iconvconfig
/usr/bin/install -c /sources/glibc-2.31/build/iconv/iconv_prog /usr/bin/iconv.new
mv -f /usr/bin/iconv.new /usr/bin/iconv
make[2]: Leaving directory '/sources/glibc-2.31/iconv'
make  subdir=locale -C locale ..=../ subdir_install
make[2]: Entering directory '/sources/glibc-2.31/locale'
/usr/bin/install -c -m 644 langinfo.h /usr/include/langinfo.h
/usr/bin/install -c -m 644 locale.h /usr/include/locale.h
/usr/bin/install -c -m 644 bits/locale.h /usr/include/bits/locale.h
/usr/bin/install -c -m 644 bits/types/locale_t.h /usr/include/bits/types/locale_t.h
/usr/bin/install -c -m 644 bits/types/__locale_t.h /usr/include/bits/types/__locale_t.h
/usr/bin/install -c /sources/glibc-2.31/build/locale/libBrokenLocale.so /lib/libBrokenLocale-2.31.so.new
mv -f /lib/libBrokenLocale-2.31.so.new /lib/libBrokenLocale-2.31.so
echo `../scripts/rellns-sh -p /lib/libBrokenLocale-2.31.so /lib/libBrokenLocale.so.1` /lib/libBrokenLocale.so.1 >> /sources/glibc-2.31/build/elf/symlink.list
rm -f /usr/lib/libBrokenLocale.so.new
/bin/sh ../scripts/rellns-sh /lib/libBrokenLocale.so.1 /usr/lib/libBrokenLocale.so.new
mv -f /usr/lib/libBrokenLocale.so.new /usr/lib/libBrokenLocale.so
/usr/bin/install -c -m 644 /sources/glibc-2.31/build/locale/libBrokenLocale.a /usr/lib/libBrokenLocale.a
/usr/bin/install -c -m 644 /sources/glibc-2.31/build/gnu/lib-names-64.h /usr/include/gnu/lib-names-64.h
/usr/bin/install -c /sources/glibc-2.31/build/locale/localedef /usr/bin/localedef.new
mv -f /usr/bin/localedef.new /usr/bin/localedef
/usr/bin/install -c /sources/glibc-2.31/build/locale/locale /usr/bin/locale.new
mv -f /usr/bin/locale.new /usr/bin/locale
make[2]: Leaving directory '/sources/glibc-2.31/locale'
make  subdir=localedata -C localedata ..=../ subdir_install
make[2]: Entering directory '/sources/glibc-2.31/localedata'
rm -f /usr/share/i18n/charmaps/ANSI_X3.110-1983 /usr/share/i18n/charmaps/ANSI_X3.110-1983.gz
/usr/bin/install -c -m 644 charmaps/ANSI_X3.110-1983 /usr/share/i18n/charmaps/ANSI_X3.110-1983
gzip -9n /usr/share/i18n/charmaps/ANSI_X3.110-1983
make[2]: gzip: No such file or directory
make[2]: *** [Makefile:310: /usr/share/i18n/charmaps/ANSI_X3.110-1983.gz] Error 127
make[2]: Leaving directory '/sources/glibc-2.31/localedata'
make[1]: *** [Makefile:470: localedata/subdir_install] Error 2
make[1]: Leaving directory '/sources/glibc-2.31'
make: *** [Makefile:12: install] Error 2
2
  • I inlined your linked logfile since the life span on termbin.com is only one month. – Freddy Mar 16 '20 at 1:06
  • Oh, thanks, my bad. – Matthew Wozniak Mar 16 '20 at 1:14
2

I've figured it out. gzip wasn't installed so I installed it and it worked

It wasn't gzip that couldn't find the file, it was gzip that was not being found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.