1

While setting up a Ryzen 3990X, Nvidia Quadro RTX 4000, 256GB DDR4, CentOS 7 machine:

Monitor : dell up2414q

Background : After properly installing CentOS 7 via USB key I was able to login to the user account in a graphical terminal. The next thing on my plate was to install Nvidia driver (v440) for X86_64.

Upon following install instructions and rebooting the machine I was greeted by a black screen instead of the login screen. The search began. I traced hundreds of forums and none of them said "why" only "what to do" and in fact none were comprehensive.

This was the best thing I found, Dave_B's answer worked after 100s of other solutions did not. I didn't even have to uninstall nvidia driver first, I just reinstalled it overtop. Once I had followed the 5 steps below, I followed the answer in this link and it worked to get me past the black screen and onto the current remaining issue: https://unix.stackexchange.com/a/560515/318683

Some things that have proven true and apparently necessary in my case.

  1. we DO need to disable nouveau, which would otherwise be in the way of the nvidia driver. done via blacklisting and adding to grub config.
  2. we DO want to modify our grub configuration file
  3. we DO NOT want to add nvidia_drm.modeset=1 to the grub loader configuration, this ends up fighting with the display manager (gdm, kde etc.)
  4. we DO want to utilize Xrandr to modify our graphical terminal; will occur at the layer before desktop manager and allow a permanent-configurable solution that persists over reboots.
  5. we want to add a Modeline in the X11 configuration file which corresponds to the resolution of the Display(s) we are using.

Essentials: At grub loader add the word "single" or the number 3 to the end of the kernel parameters; in order to boot to a usable terminal when dealing with a black graphical terminal.

The question: Now that we have the driver installed and the OS booting into login screen, how can we ensure that 4k resolution appears as 1 tile rather than 2 tiles of 1920x2160? remaining at 60Hz. The nvidia xserver GUI only displays resolutions up to 1920x1080.

Where I'm at: typing "Xrandr" shows the modes that the connected display can utilize. Most lines just have the 2 dimensions but the currently selected display resolution is highlighted by an "*"

The confusing part: I have only plugged in a single monitor(miniDP) to DP(GPU) cable but Xrandr shows 2 connected devices DP-4.8 and DP-4.9. Each of them has 1/2 the desired 4k resolution and they visually look stitched together when at login screen and once loggedin. why are the 2 sides of the screen different colors? Can this be equalized via a setting? This machine will be used in part for 3D modelling rigging animation etc and a true 4k tile with the 10bit color depth that this quadro rtx provides. So, its main use case requires it to have a seemless Display.

Thanks and I will probably add more and references to support. And please, if you find any of those 5 necessary items to be superfluous, tell me why in the comments!! :D

1

The confusing part: I have only plugged in a single monitor(miniDP) to DP(GPU) cable but Xrandr shows 2 connected devices DP-4.8 and DP-4.9.

One DisplayPort output can provide data for multiple displays: this is known as DisplayPort Multi-Stream Transport (MST). It looks like your 4k display is presenting itself as 2 separate halves, perhaps as a backwards compatibility feature?

To solve this mystery, information on the make, model and configuration of your display is required - and it looks like you told us nothing at all about it. Please edit your question to add information on your display - of particular interest would be any configuration settings referring to DisplayPort version or transfer mode in the display itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.