0

My ISP's DHCPv6 is broken. As a work around I figured I'd try IPv6 SLAAC since I do see router advertisements coming in on my WAN interface. I believe I've configured accept_ra, accept_ra_pinfo, and autoconf correctly yet I don't see any IPv6 addresses being assigned to the interface. Is there some trigger other than the periodic RA or bringing the interface down/up that are required? Are there particular options that need to be present in the RA that my ISP isn't sending?

$ find /proc/sys/net/ipv6/conf/enp8s0/ -mindepth 1 | while read path; do printf "%s: %s\n" "$path" "$(cat $path)" ; done
/proc/sys/net/ipv6/conf/enp8s0/accept_dad: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_ra: 2
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_defrtr: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_from_local: 0
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_min_hop_limit: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_mtu: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_pinfo: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_rt_info_max_plen: 0
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_rt_info_min_plen: 0
/proc/sys/net/ipv6/conf/enp8s0/accept_ra_rtr_pref: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_redirects: 1
/proc/sys/net/ipv6/conf/enp8s0/accept_source_route: 0
/proc/sys/net/ipv6/conf/enp8s0/addr_gen_mode: 1
/proc/sys/net/ipv6/conf/enp8s0/autoconf: 1
/proc/sys/net/ipv6/conf/enp8s0/dad_transmits: 1
/proc/sys/net/ipv6/conf/enp8s0/disable_ipv6: 0
/proc/sys/net/ipv6/conf/enp8s0/disable_policy: 0
/proc/sys/net/ipv6/conf/enp8s0/drop_unicast_in_l2_multicast: 0
/proc/sys/net/ipv6/conf/enp8s0/drop_unsolicited_na: 0
/proc/sys/net/ipv6/conf/enp8s0/enhanced_dad: 1
/proc/sys/net/ipv6/conf/enp8s0/force_mld_version: 0
/proc/sys/net/ipv6/conf/enp8s0/force_tllao: 0
/proc/sys/net/ipv6/conf/enp8s0/forwarding: 0
/proc/sys/net/ipv6/conf/enp8s0/hop_limit: 255
/proc/sys/net/ipv6/conf/enp8s0/ignore_routes_with_linkdown: 0
/proc/sys/net/ipv6/conf/enp8s0/keep_addr_on_down: 0
/proc/sys/net/ipv6/conf/enp8s0/max_addresses: 16
/proc/sys/net/ipv6/conf/enp8s0/max_desync_factor: 600
/proc/sys/net/ipv6/conf/enp8s0/mc_forwarding: 0
/proc/sys/net/ipv6/conf/enp8s0/mldv1_unsolicited_report_interval: 10000
/proc/sys/net/ipv6/conf/enp8s0/mldv2_unsolicited_report_interval: 1000
/proc/sys/net/ipv6/conf/enp8s0/mtu: 1500
/proc/sys/net/ipv6/conf/enp8s0/ndisc_notify: 0
/proc/sys/net/ipv6/conf/enp8s0/ndisc_tclass: 0
/proc/sys/net/ipv6/conf/enp8s0/optimistic_dad: 0
/proc/sys/net/ipv6/conf/enp8s0/proxy_ndp: 0
/proc/sys/net/ipv6/conf/enp8s0/regen_max_retry: 3
/proc/sys/net/ipv6/conf/enp8s0/router_probe_interval: 60
/proc/sys/net/ipv6/conf/enp8s0/router_solicitation_delay: 1
/proc/sys/net/ipv6/conf/enp8s0/router_solicitation_interval: 4
/proc/sys/net/ipv6/conf/enp8s0/router_solicitation_max_interval: 3600
/proc/sys/net/ipv6/conf/enp8s0/router_solicitations: -1
/proc/sys/net/ipv6/conf/enp8s0/seg6_enabled: 0
/proc/sys/net/ipv6/conf/enp8s0/seg6_require_hmac: 0
cat: /proc/sys/net/ipv6/conf/enp8s0/stable_secret: Permission denied
/proc/sys/net/ipv6/conf/enp8s0/stable_secret: 
/proc/sys/net/ipv6/conf/enp8s0/suppress_frag_ndisc: 1
/proc/sys/net/ipv6/conf/enp8s0/temp_prefered_lft: 86400
/proc/sys/net/ipv6/conf/enp8s0/temp_valid_lft: 604800
/proc/sys/net/ipv6/conf/enp8s0/use_oif_addrs_only: 0
/proc/sys/net/ipv6/conf/enp8s0/use_optimistic: 0
/proc/sys/net/ipv6/conf/enp8s0/use_tempaddr: 0
Mar 14 20:25:53 router systemd-networkd[436]: enp8s0: Link UP
Mar 14 20:25:53 router kernel: 8021q: adding VLAN 0 to HW filter on device enp8s0
Mar 14 20:25:56 router dhcpcd[127498]: enp8s0: carrier acquired
Mar 14 20:25:56 router kernel: igb 0000:08:00.0 enp8s0: igb: enp8s0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Mar 14 20:25:56 router kernel: IPv6: ADDRCONF(NETDEV_CHANGE): enp8s0: link becomes ready
Mar 14 20:25:56 router systemd-networkd[436]: enp8s0: Gained carrier
Mar 14 20:25:56 router dhcpcd[127498]: enp8s0: IAID 18:0a:25:d3
Mar 14 20:25:57 router dhcpcd[127498]: enp8s0: rebinding lease of a.b.c.d
Mar 14 20:25:57 router dhcpcd[127498]: enp8s0: probing address of a.b.c.d/22
Mar 14 20:26:01 router dhcpcd[127498]: enp8s0: leased of a.b.c.d for 205808 seconds
Mar 14 20:26:01 router dhcpcd[127498]: enp8s0: adding route to of a.b.c.d/22
Mar 14 20:26:01 router dhcpcd[127498]: enp8s0: adding default route via of a.b.c.e
$ ip addr show enp8s0 | grep -c inet6 
0
$ sudo tcpdump -i enp8s0 -vv icmp6

20:46:07.148139 IP6 (class 0xe0, hlim 255, next-header ICMPv6 (58) payload length: 32) _gateway > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 32
    hop limit 255, Flags [managed], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 6ms
      source link-address option (1), length 8 (1): 00:aa:bb:cc:01:02
        0x0000:  00aa bbcc 0102
      mtu option (5), length 8 (1):  1500
        0x0000:  0000 0000 05dc

(And I didn't redact the addresses in that last command, my ISP really is sending 00:aa:bb:cc:01:02!)

0

1 Answer 1

0

Maybe my ISP is not sending any prefixes in the RA and therefore no auto configuration can occur?!

$ sudo tcpdump -i enp8s0 -vv 'icmp6[icmp6type] = icmp6-routeradvert' 
tcpdump: listening on enp8s0, link-type EN10MB (Ethernet), capture size 262144 bytes
20:52:17.144911 IP6 (class 0xe0, hlim 255, next-header ICMPv6 (58) payload length: 32) _gateway > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 32
    hop limit 255, Flags [managed], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 6ms
      source link-address option (1), length 8 (1): 00:aa:bb:cc:01:02
        0x0000:  00aa bbcc 0102
      mtu option (5), length 8 (1):  1500
        0x0000:  0000 0000 05dc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .