When I connect my mixer to my Debian/KDE machine the sound is slowed and pitched down. Sometimes it takes days or weeks until this effect occurs.

Strangely it rarely works after restarting the mixer console. It usually works after restarting it many times.

Once it works I can change the sound output under "Audio Volume" back and forth and it keeps working.
I think it's skewing the sound more often than previously and that I need way more restarts to get it working but I might be wrong.

I already checked if there is a firmware update for my mixer console but it's already the latest version. And I tried changing the Phonon Backend from Phonon VLC to Phonon GStreamer but that didn't help. /var/log/syslog doesn't seem to have useful messages that are related to the problem.

It's a HID controller (USB, not MIDI) with an onboard soundcard and I'm using ALSA. aplay -l says the driver is module-alsa-card.c.

Any ideas what might cause this (or how to find out) and how it could be fixed?

  • 1
    How new is your mixer console? What model is it and what driver are you using? For any vaguely professional audio hardware, I would strongly consider using JACK, rather than Pulseaudio, as it should provide higher performance and lower latency.
    – Time4Tea
    Commented Apr 29, 2020 at 15:08
  • Sorry, I don't want to specify the model. I added some more info to the question. I'm not sure if JACK can be used for HID devices. So far it doesn't look like it can. Thanks.
    – mYnDstrEAm
    Commented Apr 29, 2020 at 17:59
  • 1
    This is starting to get into an 'extended discussion', but what I would try is this: install LXDE (so you're not using Phonon) and try audio with the suspect device in there. Try it with a couple of audio apps straight to ALSA (i.e. disable or uninstall pulseaudio). If you get issues with just that device and not others, then it probably suggests an issue with the driver support in ALSA. Also, I think some of the information you have shared in cmments should probably be added to the question.
    – Time4Tea
    Commented Apr 30, 2020 at 11:26
  • 3
    slowed and pitched down = sample rate is wrong. To debug, use the "divide and conquer" approach: Separate your audio pipeline into parts, test each part by itself. I.e.: Connect your mixer, make sure you see the effect. Stop Pulseaudio (pulseaudio --kill), find a WAV file, use aplay to play it directly via ALSA. Still see the effect? Then it's somewhere in the ALSA drivers and/or hardware, so start diffing there. Don't see the effect? Restart Pulseaudio, use paplay to test it. Don't see the effect? Use you Phonon backend. Etc.
    – dirkt
    Commented May 2, 2020 at 19:18
  • 1
    For now the issue is here: github.com/alsa-project/alsa-firmware/issues/7 but that may be the wrong place and insufficient info.
    – mYnDstrEAm
    Commented Dec 9, 2022 at 23:52


You must log in to answer this question.

Browse other questions tagged .