0

I want to customize my Zathura to allow me to type #name_of_a_bookmark, hit Enter and get sent to this bookmark.

Based on the answer of another question on this site I figured out that this can be done using the map command in the zathurarc file and the command should be similar to this: map # focus_inputbar ":blist ".

Then I found out that this doesn't work because # is the symbol which starts a comment in the zathurarc file. (Using another symbol like - instead of # worked so everything else in the command is correct.)

Is there a way to escape # in the zathurarc file so I can use it for key bindings?

4
  • Doesn't simply map \# ... works? (not able to test it right now) Mar 13 '20 at 9:35
  • I don't know - I can try it in a few hours when I'm home again. The reason I didn't try \# is that I didn't realize that # is the comment symbol when I tried to use my command. Just now I read more about zathurarc commands and saw this as a comment symbol.
    – Marv
    Mar 13 '20 at 9:37
  • I've tested it on zathura 0.4.3 (debian 10) Mar 13 '20 at 10:13
  • Nice thanks, I'll accept your answer as soon as I can test it today (provided it works but I don't see a reason why it wouldn't).
    – Marv
    Mar 13 '20 at 10:17
0

Simply escaping it with a backslash works.

map \# focus_inputbar ":blist "

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.