3

My OS is [03/13/2020,14:35:06@~]$ uname -a Linux debian 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux That is, Debian 10 (Buster). When in Debian 9, I can make annotation in djvu file with Okular. But now I cannot. Below is a typical process of trial.

Start Okular. Open with Okular, a djvu file named 1.djvu. Now use Hilighter4 to make some annotation. Then close the file 1.djvu. Thus, a popup reads: Do you want to save your changes to "1.djvu" or discard them? (see screenshotenter image description here) I choose "Save". Then another popup says:Warning-Okular You are about to save changes, but the current file format does not support saving the following elements. Please use the Okular document archive format to preserve them. So, I click "Use annotations", and then choose "Save as Okular document archive...". (See screenshotenter image description here) Now also a popup reads "After saving, the current document format requires the file to be reloaded. Your undo/redo history will be lost. Do you want to continue?" I choose "Yes". (See screenshotenter image description here) And the file 1.djvu is saved as 2.djvu. Now I open 2.djvu by Okular. But a popup reads "Could not open file:///.../2.djvu". See thisenter image description here. How can I solve this problem?

1

Rename the file so that the file extension is .okular instead of .djvu. This worked for me.

2
  • Wow! This solution is so messed up! Thanks! I had this problem too. – SasQ Feb 2 at 13:55
  • Dammit, after reopening the .okular document, adding some more annotations, and trying to save them again, it said that the changes cannot be saved because the file has been modified by another program (the one in which I was viewing it, no doubt :q ), even when I tried to "Save As…" with a different name. And after closing the file and opening again, all my changes are lost! ;o So neither can I update the annotations nor save a new file with more annotations. Any solutions for that? :q This is getting really ridiculous and annoying. WHO MADE THAT?! ;o – SasQ Feb 2 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.