0

I have a WNFQ-258ACN(BT) wireless network card installed in a PICO-KBU4 board. It is running Yocto Linux.

When I make ifconfig no wireless interface shows up. When I list PCI devices it shows up [disabled]:

# lspci -vnn

01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Device [1dac:0258]
    Flags: fast devsel, IRQ 11
    Memory at df000000 (64-bit, non-prefetchable) [disabled] [size=2M]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/8 Maskable+ 64bit-
    Capabilities: [70] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [148] Virtual Channel
    Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
    Capabilities: [178] Latency Tolerance Reporting
    Capabilities: [180] L1 PM Substates

I have loaded the driver ath9k.

# lsmod
[...]
iwlwifi               241664  0
ath9k                  94208  0
ath9k_common           16384  1 ath9k
ath9k_hw              421888  2 ath9k_common,ath9k
mac80211              544768  1 ath9k
ath                    28672  3 ath9k_common,ath9k,ath9k_hw
cfg80211              499712  5 ath9k_common,ath9k,ath,iwlwifi,mac80211
[...]

Why does it appear disabled? and how can I enable it?

EDIT:

root@aaeonc:~# rfkill list all
0: hci0: bluetooth
        Soft blocked: no
        Hard blocked: no
3
  • You need the ath10k driver.
    – Freddy
    Mar 11, 2020 at 14:34
  • Please edit your question to show the result of the terminal command: rfkill list all
    – chili555
    Mar 11, 2020 at 15:06
  • ath10k is not an option when I run menuconfig for Yocto. However I am using kernel 4.14.76 so I don't understand why it is not showing up
    – Sanjo
    Mar 11, 2020 at 15:13

1 Answer 1

0

As Freddy mentioned in comments, ath9k does not support my device, so the solution is install ath10k driver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .