0

I have installed a TrueOS 13.0-CURRENT desktop system with cups 2.2.8 installed from pkg. Printing works like a charm, but cupsd is not starting at boot, despite this being in /etc/rc.conf:

cupsd_enable="YES"
devfs_system_ruleset="system"

sudo service cupsd start has to be run after boot to start it. It works fine, but it should start at boot.

During the boot output where it shows the services being started, there's no visible error; it just doesn't mention any attempt to start cupsd.

2
  • What is the output of systemctl status cupsd? Maybe the service is just not enabled in which case you could try systemctl enable cupsd – BulletBob Mar 9 '20 at 14:35
  • This is TrueOS, M. Krall. – JdeBP Mar 9 '20 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.