1

I am using cygwin on Windows 10, to ssh to my servers, and recently I noticed that whenever I pressed CTRL+o the entire session/cygwin window would freeze up. I tested it out on putty as well and same thing happens. I have also noticed that pressing CTRL+o again causes it to unfreeze.

I am pretty sure this did not use to happen before, as I use nano text editor usually and CTRL-o for saving the file. This is causing a lot of frustration now as every time I try to save a file the whole session gets stuck.

Also I have tried stty -ixon command but it did not help and it seems unrelated to CTRL+s and CTRL+q.

Any ideas what might be causing this and if it can be disabled?

1

Do you have by any chance NZXT Cam software running? The default hotkey to activate it's overlay is Ctrl+O. Remove the assigned hotkey in NZXT Cam Settings > Overlay and you should be good.

| improve this answer | |
  • I do have the NZXT Cam software running. I will try to turn that off and get back to you. – Wajahat May 11 at 4:55
  • That was the problem. I am not sure if that is intended behavior of CAM though. – Wajahat May 11 at 5:00
4

Check out stty:

~ (101) stty -a
speed 38400 baud; rows 40; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol = <undef>;
eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; discard = ^O; min = 1; time = 0;
-parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany -imaxbel iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke -flusho -extproc

Special characters:
* discard CHAR
CHAR will toggle discarding of output

(your settings may differ...)

The manual page says also

In settings, CHAR is taken literally, or coded as in ^c, 0x37, 0177 or 127; special values ^- or undef used to disable special characters.

| improve this answer | |
  • Yes that is set to this : discard = ^O , is there a way to change that? Also, this started occurring only recently, do you know what could be the reason? – Wajahat Mar 9 at 0:29
  • Perhaps some update set the value. You can use stty to set any of those to a undef (undefined) value to disable them. – Thomas Dickey Mar 9 at 0:52
  • I disabled it, but the freeze is still happening upon pressing ctrl+o – Wajahat Mar 9 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.