0

I'm installing Ubuntu 18.04 LTS on a Dell Inspiron 5559 with 1 TB HDD where WIndows 10 is already installed, hence it's a dual boot. I have set up a Ubuntu bootable USB drive and booted Ubuntu in UEFI mode from it. I have disabled secure boot, fast boot and created suitable partitions on Windows already.

The installation starts smoothly but fails again and again with the message "unable to install GRUB on dev/sda1" and says that it is a "fatal error". /dev/sda1 is the EFI boot partition (ESP partition) on my HDD to which Windows Boot Manager is installed. I had read that GRUB bootloader must be installed to that partition.

I am somewhat certain (but not completely) that the Ubuntu OS installed perfectly and the problem cropped up only in the GRUB installation, since whenever I try to re-install, the setup wizard says that "this computer has Windows 10 and Ubuntu 18.04 LTS on it" and gives the option to "Erase Ubuntu 18.04 LTS and re-install", which would only be possible if Ubuntu was already installed.

I have tried boot-repair, which says that that there was an error during repair due to which it could not be completed. Pastebin : http://paste.ubuntu.com/p/J3dk2YGBqG/

I'm a complete newbie at Linux/Ubuntu and would be grateful if anyone can provide a solution to this problem.

0

Ok, from what I see on the dump, there is an error in grub-install itself. Checkout line 1123.

So at this point I suggest this.

  1. First try to update grub, perhaps there is a version that fixes the syntax error

Boot to your live Ubuntu. Open terminal ctrl+alt+t and run

sudo apt update
sudo apt install --reinstall grub

And try bootrepair again.

  1. If that still doesn't work. Like you said, your Ubuntu successfully installed and yes, you are right on that. Do this.

Get another Linux distro is, could even be an older Ubuntu, all we want is a working grub (or some linux recovery tool iso...not sure how Linux boot recovery tools work I usually fix these kind of errors manually).

Run boot repair from there, AND make sure you don't first upgrade grub cause it might upgrade to the broken one.

| improve this answer | |
0

"/dev/sda1 is the EFI boot partition (ESP partition) on my HDD ... I had read that GRUB bootloader must be installed to that partition."

What drive did you select during the installation of grub?
You actually should select /dev/sda and not /dev/sda1 as this is a partition.
install-grub should than find the right partition by itself. In your case that would then be /dev/sda1.

| improve this answer | |
0

On my tower system I switched the order the discs are physically connected to the motherboard via SATA - once the SSD I was trying to get Ubuntu 18.04 onto was first in the list that Ubuntu displays as it boots, this all went fine - no "fatal grub error". Sadly I can't now find the original tip that pointed me in this direction (I'm neither a native Ubuntu guy nor a hardware guy!!) and I appreciate that messing about with SATA connectors in a laptop isn't desirable or sometimes even possible, but this worked for me. Essentially you're making the target disk to be /dev/sda - bit of a bodge but life is short.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.