So I did something stupid, but deliberately.

So I've been using Linux (specifically MX Linux) for a few months, and I'm trying to learn it all in depth. Since coming from Windows 7 I like everything except how to install software there is a dependence on updating from the internet. So I've been playing with using the .deb packages and trying apt-offline to do so.

I wanted to try and see if the R (for R markdown) would install offline. Being new to linux I couldn't really figure out how to purge the R installation files, so I just typed in: whereis R and deleted the files it gave me. Now I remember one was like a bash file I believe. I have reinstalled R and currently when I type in whereis R, this is what I get: /etc/R /usr/share/R /usr/share/man/man1/R.1.gz and the bash file is not there. I believe as a consequence of this when I type in the terminal: R it says bash: R: command not found

Does anyone have any tips regarding anything I've said here (I'm not an expert in R either btw). But specifically what am I missing to get R to run from the terminal again?


  • How exactly did you reinstall R? it looks like you are missing /usr/bin/R, which would probably be provided by package r-base-core on Debian-derived systems Mar 8, 2020 at 2:28
  • Thanks for the fast reply. As I alluded to, I'm a bit insane. So I'm trying to build up my own sort of off-line repository so I usually download the last few stable release .deb files in both AMD64 and i386. I believe I installed r-base_3.3.3-1_all.deb and r-base-core_3.3.3-1_amd64.deb, so I'm not sure why /usr/bin/R wouldn't be installed.
    – 1toneboy
    Mar 8, 2020 at 2:46
  • I did a: dpkg -c on the r-base-core.deb and /usr/bin/R is among the contents, but as you say it's not installed for some reason?
    – 1toneboy
    Mar 8, 2020 at 11:37
  • Ah fixed it. So I purged r-base-core and reinstalled it, and it worked. Funny, I already tried reinstalling it, but it seems, it had to be purged first. Thanks!
    – 1toneboy
    Mar 8, 2020 at 11:42


You must log in to answer this question.

Browse other questions tagged .