1

I have a Dell Latitude 7400, which came with Windows 10 OS. I'm trying to install CentOS in it, but the CentOS installer is not detecting the internal SSD. My Laptop Configuration,

System Type                   x64-based PC
System SKU                    08E1
Processor                     Intel(R) Core(TM) i5-8365U CPU @ 1.60GHz, 1896 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date             Dell Inc. 1.3.11, 6/11/2019
SMBIOS Version                3.2
Embedded Controller Version   255.255
BIOS Mode                     UEFI
BaseBoard Manufacturer        Dell Inc.
BaseBoard Product             07WDVW
BaseBoard Version             A01

Storage Info,
Manufacturer                 (Standard disk drives)
Model                        SSDPEKKF256G8 NVMe INTEL 256GB

CentOS Version - CentOS-8.1.1911-x86_64

I have to get the CentOS installed in my Laptop, if Possible with Dual-Boot option, with Both OSes - Windows 10 and as well as CentOS 8.

If I connect a External SSD, then it is getting detected and i've been able to install CentOS in it. I've been able to boot from the External SSD. But I would like to get the CentOS installed in the internal SSD.

Can somebody help me with this. I've tried CentOS forums, StackExchange - answered questions, but so far, nothing worked.

enter image description here

3
  • 2
    From : centosfaq.org/centos/centos-installer-not-detecting-hard-drive :Some notebooks need a change in the BIOS – the section where the disk controller is set to either AHCI or RAID or . Linux needs the controller in AHCI mode. If you set it from RAID to AHCI, then your Windows (if you plan to dual-boot) might not start anymore because its drivers expect the controller in RAID mode. This can typically be fixed – google for it
    – Madhubala
    Mar 7 '20 at 17:01
  • Is the partition to which you are trying to install CentOS 8 have ntfs as its file system? Mar 7 '20 at 19:28
  • @NasirRiley No, it's an unallocated space. Mar 8 '20 at 2:00
2

Thanks @Madhubala for the solution.

Linux needs the controller in AHCI mode. So i've set it up from RAID to AHCI, then the CentOS installer detected the Hard Drive and I installed the OS. I expected, i won't be able to boot into Windows. To my Surprise, i'm able to boot into both OS. Dual Boot works as well.

0

Make sure to shutdown Windows completely and not using hybernate or suspend options, and also deselect fast boot, otherwise the disk may result in a locked state.

7
  • I have shutdown completely. I'm in the Boot Screen. I don't see any Fast Boot option in BIOS. Mar 7 '20 at 16:43
  • Fast boot also known as fast startup is something you have to disable inside Windows from the power options. Check this link to see how to disable it link Mar 7 '20 at 16:52
  • I don't think it has anything to do, when CentOS is trying to detect the hard drive. Mar 8 '20 at 1:59
  • Did you try disabling fast startup first and then doing a clean Windows shutdown first? Mar 8 '20 at 14:25
  • Still you are looking it inside Windows. It doesn't affect CentOS installer. Mar 8 '20 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.