-1

Since enhanced session mode is not officially supported by Microsoft for Ubuntu 19.10 and Ubuntu 18.04's developer tools are hopelessly outdated, I tried to get it to work.

I found the following modified version of Microsoft's official script: https://gist.github.com/mimura1133/a6aebf4945b6688d1a5aedffdfa9368c

I installed the script including running it again after the first reboot (as asked).

Before the second reboot, I activated EnhancedSession Mode for the VM. However, it does not work. Nothing has changed. There is no prompt for the screen resolution or the XRDP login screen.

My Windows 10 Version is: 2004

The build is: 19569.1000

Does anyone know how to get this to work? The only other viable alternative is using VMWare Workstation and play the reboot game.

0

I installed Ubuntu 19.10 using Quick Create. I did various stuff, but I got it working consistently was:

  • after starting the VM
  • waiting for the VM CPU usage dropping to 0% and
  • only then clicking "Connect".

It behaves as if if graphics output is used, RDP server fails to start.

| improve this answer | |
  • My problem was that Ubuntu 19.10 was not listed under Quick Create unlike it is now. Obviously, if it is listed, you should most certainly use Quick Create instead of my instructions. That being said, I needed to develop on a project using way more modern tools than Ubuntu 18.04 provided and trying to get it to work on Ubuntu 18.04 was a much bigger time sink than getting Ubuntu 19.10 to work which shipped everything I needed as a supported configuration. – Willi Apr 5 at 16:23
0

(UPDATE: Back when I needed this, Ubuntu 19.10 was not listed under Quick Create. This, however, has changed. I would recommend using Quick Create, if possible, over my solution I provide below.)

I fixed the problem myself. Unsurprisingly, Gnome turned out to be a problem. Since I am not a fan of Gnome, I did not bother to make Gnome work with xrdp. Since xrdp is a necessity to get EnhancedSession to work, I chose an alternative desktop environment: Mate.

I reinstalled Ubuntu using the server iso in order to have more control of what gets installed and what not. While the server iso is nice for finding the source of the problem, I would not necessarily recommend it. Just choose a flavor of Ubuntu using something like mate or xfce.

Once you have a Gnome-free Ubuntu 19.10 with an alternative desktop environment that plays nice with xrdp, you need to download the following script: https://gist.github.com/mimura1133/a6aebf4945b6688d1a5aedffdfa9368c

Extract the content of the zip file and mark it as an executable (IMPORTANT!). Run it as root (with sudo). Reboot once the script has finished. Run the script again (also as root).

For completeness sake, I should mention, that I followed the following instructions to rid myself of Wayland: https://linuxconfig.org/how-to-disable-wayland-and-enable-xorg-display-server-on-ubuntu-18-04-bionic-beaver-linux However, this should not be necessary, since the script has already dealt with Wayland, or at least it should according to the guy that modified it to work with Ubuntu 19.10.

Once the script has finished for the second time, do not reboot, like the script tells you, but turn the VM off.

Open PowerShell as administrator and enter the following line: Set-VM -VMName <your_vm_name> -EnhancedSessionTransportType HvSocket Do not forget to replace <your_vm_name> with the name of your virtual machine.

I hope I did not forget any step that was necessary to get this to work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.