0

After installing the vagrant packages on Fedora 31 and subsequently running the vagrant command, there are these errors regarding ignored Rubygems:

Ignoring ffi-1.10.0 because its extensions are not built. Try: gem pristine ffi --version 1.10.0
Ignoring json-2.2.0 because its extensions are not built. Try: gem pristine json --version 2.2.0
Ignoring unf_ext-0.0.7.6 because its extensions are not built. Try: gem pristine unf_ext --version 0.0.7.6

The command still visibly works, however after additionally installing vagrant-libvirt as I need some form of provider, even more ones pile up, and attempting to build Valve's Proton via Vagrant results in an error about Vagrant not finding nokogiri.

How can I go about building these extensions? I tried the suggested commands, however it appears that they try to fix gems installed locally inside my user's home directory and not the ones installed by dnf when installing vagrant (located in /usr/share/gems/gems/).

1 Answer 1

0

The issue was due to me previously having installed rvm from its website. Removing rvm via the command rvm implode and restarting my shell resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.