For a class I have to run minix3 on virtualbox and make changes to the kernel. This is fine on my laptop. However, on my desktop, I am constantly running into issues with memory. For example, whenever I have to run 'make build' in the /usr/src directory to build the source code, I end up with the verify_grant: grant failed or something error in the do_safecopy.c, which I presume is an issue with memory. Weirdly enough, if a make build fails, and I try to run something else, I get a kernel panic.

Today, I also tried to give minix some more memory, and I got one of the make commands to run fine(the make services command in the /usr/src/releasetools director) but only once, and when I powered down the vm to come back and try again, same error with this verify_grant message. Oddly enough, when I use to run java programs on this ubuntu machine and I would use Runtime.exec() to spawn a new process, and would call for the process to be killed, it wouldn't do so and I would have to manually kill it from the terminal using the pid. I think these issues could be related but I am unsure.


  • Ubuntu 19.04

  • Virtualbox 5.2

  • AMD Ryzen 5 2600
  • Gigabyte B450M Motherboard
  • 16GB Memory (i forget the brand)
  • Radeon RX580

I really appreciate all the help!

2 Answers 2


Verify the configuration of the virtual machine you are using (RAM, disk, perhaps other configuration pieces).The physical machine as itself should be extravagantly over-resourced for Minix, that can't be the problem.


Try disabling nested paging. In my case the compilation worked. But it will take ages. Still looking for better solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .